Problems with Iconfig since updating to 4.2.4 and latest firmware

edited May 1 in Software
Hi, 

I am not sure if these issues are down to iconfig or the firmware since I upgraded both at the same time.

However I am finding that:

1)  When launching iconfig it is now taking ages to "find" and connect to the device.   Used to take 2 seconds, now takes nearly 30 seconds.
I have seen this mentioned elsewhere and also a reply to say that it is Windows that takes a long time to scan the USB ports.  That cannot be the reason however as prior to update of iconfig and firmware it was fine.

2)  Sometimes when changing presets the device reboots and then is not found at all.  The ASIO control panel shows no device connected, the iconfig software doesn't even appear to be searching.  The only solution is to reboot PC.  This seems to be a significant bug - it seems like the device, or the driver has crashed.


I think I *may* have some information that is helpful however:  [EDIT: IGNORE THIS. Must have been a coincidence, I now have issues even without ipad connected]
My normal setup is with an iPad connected to usb port 1 (as that's the one which provides power) and my PC connected to usb port 2.  I have not tested extensively, but it seems like the crash only occurs if the iPad is connected.  If I have the iPad unplugged the device reboots and connects again correctly (albeit it takes too long as per point 1 above).   
I wonder if there is something in the way the app or the firmware is written that means it doesn't make a connection to usb 2 if there is something connected to usb 1?

Anyway, if anybody else has a similar problem, try disconnecting your idevice from usb1 temporarily while you are changing the preset and then plug in again afterwards.


3) MIDI info tab does not seem to save the tickboxes.  Sometimes even though they are empty they work, but sometimes they don't work at all.

4) The device has crashed on me (as in disappeared  - Windows can't find it) when I change audio settings, ie from 16/44.1 to 24/88.2.  Seems random, haven't worked out when it is yet.  Could be the same problem with rebooting and not connecting again if there is a device plugged in to USB 1.  

 
«1

Comments

  • edited May 1
    This is really frustrating.  Just now using Propellerheads Reason:

    Everything working fine however the audio settings were at 16/44.1 (because that's the default I use when I am using my PC for anything other than audio production). 

    I open up iconfig and switch to 24/88.2. Commit & Reset.

    Reason says my audio device has stopped working.  However I can de select and re select the iconnect ASIO device in Reason again so that's OK.

    However MIDI devices are not working!  Audio still working seems to be working fine but no MIDI input!

    Check the MIDI info tab in Iconfig and all the boxes are unticked.  Tick them all, still nothing.

    Try to load a preset in Iconfig, device starts to reboot but the iconfig doesn't find it.. no device connected by the ASIO control panel or Reason either.

    Have to reboot PC.

    Then when I load Reason I have to add the midi devices again.



    All of this is without the iPad connected to USB 1 by the way so rules out what I thought was happening before.


  • In case this is useful:

    One of the main issues is that sometimes when you make a change that requires the iconnect device (mine is the ica4+) to reset, it doesn't come back on line.

    If I look in device manager, it says:

    [quote]Windows cannot load the device driver for this hardware because a previous instance of the device driver is still in memory. (Code 38)
    The driver could not be loaded because a previous version of the driver is still in memory.
    [/quote]

  • I'm trying to get some help with this, deepbeep...


  • edited July 3
    I have the same problems. I am on Windows 10 and connect my iPad on port 1 and pc on port 2.

    I was fine after firmware update and I did a lot of configuration changes with reboots of the interface with no issue (except taking a very long time to find the interface compared to previous firmware/iConfig).

    After first connection of my iPad, the windows asio driver and iConfig have developed the problems as deepbeep. I tried reinstalling driver but same problem.

    iPad connectivity to ica4+ is working fine with no issues.
  • Are you using the latest Windows driver? Did you uninstall the previous Windows driver before you installed it?
  • hello, 
    sorry for my english i'm french !
    yesterday i updated the firmware of my iconnectmidi4+ and now impossible to access to iconfig ! same thing on the mac and with the iPad !
    all works, midi, audio, the iconnectmidi4+ is in the audio/midi setup but your app "iconfig" can't see the iconnectmidi4+. 
    i tried to change the version with the last beta but same thing !
    How can I go back and load the latest firmware that worked well ???
    thanks
  • We are testing this in-house now and it appears you may have discovered a bug! 

    You can downgrade to an earlier firmware in an emergency by using any standard MIDI Player to load it. The free version of Sweet MIDI Player should work fine.


    Hold down the button on the front panel for a few seconds to put the device into bootloader mode then simply play the firmware file via the Sweet MIDI Player. 

    Hopefully that will get you running again until we figure out what's happening.
  • where can i find an older firmware. your method doesn't work with the 1.0.8 and the beta firmware. I don't find on your site an older firmware.
    thanks
  • I think Bob from Support sent you an earlier firmware version and got this working now, right? Or was that someone else?
  • Recently I purchased two mio10, and I have same issue. I disconnected YAMAHA Montage USB cable, and I cleaned registry using KORG USB driver uninstall utility.Then I uninstalled Steinberg YAMAHA USB Driver 1.9.10-2. It still takes 30 seconds to come up the device list, but I can enter the program normally. But I still encounter the error message when I change the device. Restarting iConfig is required.
Sign In or Register to comment.