Devices tested with USB Host Port connection

2

Comments

  • Glad you got it all working, and thanks so much for the test results - I will add them to the official list now.
  • edited June 30
    A mate joined with a
    Novation Mininova and we gave it a try.
    It's not listed in iConfig after plugging into the host port and it does not respond to usb fired midi events.
    So it can be listed as not working

  • edited July 8
    Hi bought a MIO4 and been going through my gear and seeing what I can pull out of the old DIN network.

    Tried out my old Novation Remote 25, but I think it might need more than buss power as it dimmed up when I connected it.  I haven't found a psu for it laying around, so that is still untested really, but I have high hopes of it working once I do get it some wall wart power.
    The Circuit was another that acted strangely though it could have been due to a poor quality hub not coping with the number of devices on it, so again I need to revisit it now I have a better hub and have my head around what info it actually responds to.  It's a funny little box as far as MIDI goes.

    I'm running a myriad of sequencers and synths and am testing from a powered 6 port hub generally with a Pyramid, Keystep or Beatstep Pro as the source.  I have an old MIDI analysis box I'm using to check what messages are making it.  I've routed the CC data from USB attached devices to a QY700 and am catching it all there.  All seems to be the way it should with working devices.

    Tested:
    Novation Remote25, ZeroMKII, Circuit
    Waldorf Pulse 2, Blofeld, Streichfett
    DSI Tetra
    Wave Ideas Bitstream 3x
    Squarp Pyramid
    Arturia Beatstep Pro

    Working
    Novation Zero SL MKII (just making sure mine wasn't a dude)
    Waldorf Pulse2
    DSI Tetra
    Wave Ideas Bitstream 3x
    Squarp Pyramid

    Yet to be tested
    Behringer BCR-2000
    Arturia Minibrute
    Novation XStation

    Retesting either directly connected or with ext. power
    Beatstep Pro
    Remote 25
    Blofeld
    Circuit

    I'm not going to be using either of the Arturia sequencers directly connected to the MIO4 as I'd rather them to be freely routed via my patchbays.  They both end up in the MIO4 via the controllers regardless, so I'm not going to bother double checking my Keystep works, but I will exhaust all avenues with the Beatstep Pro, just need to find my Y cable for it first....

    I'm surprised the Blofeld is not being seen as both my other Waldorf synths with USB are working, no worries.  I'm going try again directly to the MIO4 and also a different power-up sequence for the devices.

    Very pleased with my MIO4, which I initially had earmarked for running as a MIDI filter to reign in some problematic reset messages the QY700 likes to send at the beginning of sequences and never intended to use the USB host.  Now I have it running middle-man for coordinating two MIDI patchbays and an automated mixing desk.
  • Okay, tried the Remote25 under power to the MIO4 via a hub and directly with no joy.  Then I remembered that it was an absolute nightmare to make work with a computer years ago when I first got it.  My crappy Edirol was a plug'n'play fairytale but this was determined to not play ball.  Works well as a simple splitter/router, too bad that did extend into the USB world.

    Next the Minibrute with was seen no worries but wouldn't respond to anything sent to it but was sending notes and mod/bend wheel data.  I did my best to find out what the Minibrute responds to via USB and found a post on their forum stating it could be sent MIDI via USB though nothing I did effected the synth.  I didn't check the 'hidden' parameters only controllable via MIDI, but am fairly sure it'll get them, just Arturia really did have an ethic of "this is an analogue synth" to the point of if they could have got away with putting no MIDI on it at all and run the thing entirely on CV, they would have.

    Now the Blofeld.  What a shame.  Like the Remote25, it just didn't like the MIO4 at all.  Not from behind a hub, not connected directly, not when powered while connected, not connected after power-up, not connected prior to the MIO4 being powered up, not in any way, shape or form.  Bugger.  The other two were so easy and put a huge smile on my face when I saw them there.  Oh well, not that it would have provided me with any extra functionality, as I more use the Zero to access it's parameters.

    And the last one I did last night was the Beatstep Pro.  This one was a worry before I hooked it up due to all the issues users have posted on their forum about getting it to play nice with DAW's.  It's also loves to bring the noise if it's 'power' cable is too near others or running straight into a computer.
    I found their solution to the noise, the USB Y power adaptor and tried it out.  Remembering something I read about getting it to work on a computer, I plugged the power to it first then plugged the 'computer' end into the hub.  Low and behold, two ports show up in iConfig.  Woohoo!  All well and good, but are the doing anything?  I only tested port 1 and only for receiving data from the BSP.  Not a problem, everything worked as if it was running from the DIN ports.  I have to mention though, the BSP is on firmware v2.0.0.x and it wasn't when I first tried it with the MIO4.  Dunno if that made any difference as I only tested the BSP from behind a hub and figured if it's working from there, all should be good connected directly.

    So, the tl;dr version:


    Working

    Arturia
    Minibrute
    Beatstep Pro


    Not Working

    Novation
    Remote25

    Waldorf
    Blofeld

    I'll get to the last few machines tonight.
  • edited July 10
    Weird, I can't find the options/edit button for my posts so have to triple post, please excuse my for decorum!

    I retried the Minibrute as I thought it weird that it would be sending data yet not receiving and I got it to sound, so that is fully working and not just a MIDI implementation.  Oddly though it has two ports showing up but only one sends and receives....

    Worked how edit works.

    XStation is working, on bus power from a powered hub.
    Seems the XStation is like my old '88 corolla, I just left it for a while and now the screen works.
  • Thanks very much for this valuable input. 

    Oddly enough I just got a Blofeld keyboard last week (birthday present for myself) and it's working perfectly plugged into a hub into the Host Port of my iConnectAUDIO4+, so it should work on your system. I'm running firmware 1.23 with all other parameters set to default. Not sure why you are having problems there... That's a wonderful synth, I'm very happy with it :-)
  • Have now updated the FAQ to reflect your findings. That's really helpful, thanks so much!
  • edited July 12
    You are very welcome.  I think that iConnectivity have a great range of products and I love that I get to put a white lab coat on for a little bit while getting my MIO4 integrated.

    With the Blofeld, I had some problems with mine when I updated from 1.03 to 1.23.  Some things went wonky and I reverted to an earlier OS but there were still some non-crippling residuals that didn't affect the sound or any programmablity, so I never really worried about going all the way and correcting it complete.  I've just corrected the other issue now (missing wavetable names and garbled 'analogue' wave images), so hopefully the USB connect with work more stably with the MIO4 also.
  • The Rhythm Wolf.  Working.

    Forgot it had a USB port.  It was sitting on it's own output on the MIO4, but is now on the USB hub.  It's playing very nicely and sending it's sequencer notes out too.  I have it clocked by a gate out from the BSP so I can have it step at will and also play it with the BSP.  Now it's not so messy in there.
  • Good to know, have fancied getting one of those myself ;-)
Sign In or Register to comment.