USB hubs working with Host port

Since we've had so many great responses to the list of working / not working MIDI devices on our Host port, I'm thinking of making another list for working / not working USB hubs. 

If any of you have a USB hub plugged into one of our USB-MDI Host ports, could you let us know in this thread what the brand name and model is please? Conversely if you have a hub you know is problematic, let us know that too.
«1

Comments

  • Mine is a chinese "i-tec" USB 3.0, 4-port charging hub (search for "I-TEC U3HUBMETAL4"). No probs so far.
  • edited August 5
    I use Amazon Basic 10 port USB 2.0 hubs on the USB host ports of my iCA4+ and mio10. They work for that purpose without a problem. $22.

    https://www.amazon.com/gp/aw/d/B00GGYU46O

    Apparently they are popular - 3 to 5 month waiting time. There's a USB 3.0 version for twice the price, as well as other models with fewer ports, though I can't speak for them. I use the 3.0 version for other peripherals on my PC, but it's overkill for this purpose.
  • Welp, I've tried 2 hubs so far.. a (Sabrent 13 Port High Speed USB 2.0 Hub with Power Adapter), and an (IOGEAR 7-port USB 2.0 Hub). NEITHER of them were recognized by ICM4+. There's no point returning the Sabrent because it cost ($20), but will cost $8+ to return it. I can do a (FREE) return if I personally drop it off at an Amazon drop point, which is DOWNTOWN! It will cost about $8+ in gas just to get down there and back... so I might as well keep it. I'm going to take the IOGEAR back tomorrow... More gas wasted!! 

    I must say, this is one of the most frustrating products I've ever used!! It's a good idea, but it seems to be on the FRINGE of the new concept of using USB for MIDI, so therefore the hardware for it is lacking, flawed, and lacks continuity across the industry. Like when cars first started being made.. If you had a mechanical problem, or even a flat tire, or needed brakes - you were pretty much screwed! Because no one had parts or knew how to do repairs yet. 

    Well, that's kinda what ICM4+ seems like to me. A new car - in a world of horse & buggy's.

    I think ICM4+ could be GREATLY improved if they followed a few basic steps... 

    1). The USB HOST port function is just about WORTHLESS right now because it's not compatible with anything on the market - BUT THIS IS EXACTLY WHY I BOUGHT IT - TO USE USB FOR MIDI!!!  >:( 

    In the Youtube ICM4+ Tutorial videos, they were using a 7-PORT USB PORT from BELKIN. Well, after wasting time & money on the Sabrent, I looked at that video again to find out what the guy was using on that video - and I saw the Belkin. I looked it up... but of course - IT'S DISCONTINUED, because it's OLD technology now, but it's still for sale on Egghead's website. But when you look it up - a warning also pops up that this product is known for containing HARMFUL CANCER CAUSING CHEMICALS!! But you can still buy it if you want. LOL (This is all true!). smh.. 

    So I'm going to try this "Amazon Basic" port (Northerntao) mentioned - this will be hub #3... oops #4 - I canceled another HUB purchase I made today!! smh.. Now I just have to wait ANOTHER damn week for this Amazon HUB - great! >:(  (NOT GOOD BUSINESS GUYS!! ... NOT GOOD AT ALL!!!)    Now I have to burn up more gas taking this IOGEAR back to Microcenter smh. 

    2). On your next ICM+ product, ICONNECT REALLY needs to make it with a USB 3.0 version, and a USB-C version!! USB 2.0 is obsolete, and it's getting EXTREMELY DIFFICULT to find hubs for that standard - ESPECIALLY when your product is only compatible with 3 or 4 of them out of the whole market!! YOUR PRODUCT NEEDS TO BE COMPATIBLE WITH WHAT PEOPLE HAVE ACCESS TO - IF IT ISN'T, AND IT REQUIRES (SPECIFIC HARDWARE) - THEN YOU NEED TO PROVIDE THE HARDWARE WE NEED IN ORDER TO USE IT!!! SO START SELLING THE HUBS WE NEED! 

    3). ON YOUR HOMEPAGE - AT LEAST POST A DAMN LIST OF COMPATIBLE 3.0 & 2.0 HUBS (that are currently available, AND UPDATE IT EVERY 5 OR 6 MONTHS)!!! AREN'T YOUR PEOPLE TESTING THIS STUFF OUT BEFORE YOU SHIP IT?? 

    Do you even care that your customers are having all these compatibility problems with your product? smh.. You apparently KNOW people are having these problems, so you need to be UPFRONT about it on your Youtube videos and on your website homepage, and TELL PEOPLE what you are doing to fix the problem, and provide people with WORKAROUNDS so that we don't waste so much time trying to get your product to work.

    ICM4+ has the WORST INCOMPATIBILITY ISSUES I'VE EVER SEEN - AND IT PISSES ME OFF THAT I'VE WASTED SO MUCH TIME & MONEY TRYING TO GET IT TO WORK RIGHT!!! 
  • I am using this one with no problems - but I just saw it's discontinued too! :-(

  • Nice use of color there rcbiz! :-)

    No, we don't test all USB hubs, because there are literally hundreds of them (maybe thousands) and as you've already seen, they seem to get discontinued every couple of weeks and replaced with other models. Not only that, manufacturers often change the internal components without telling anyone, so even if we both buy hubs that look the same there's no guarantee that they will each work the same.

    Generally speaking though, most hubs work fine. In fact, we have had difficulty finding hubs that don't work. That's why I asked people if they could give us some feedback on it. You seem to have had really bad luck though - sorry for that!

    But you make some good points. Let me have a think about it and see what we can do.

    Rodney
  • I picked up the Amazon Basic 10 port mentioned above.  Success!  My USB-MIDI device controllers / Synths are now recognized in ICM4+ when connected via the Hub.  Thank you for the mention of this.  As a bonus.. my old USB Hub is now being used to extend the USB ports on my iMac  ( USB Mouse,  OB-6 NPRN (I use it for the SoundTower integration)).   

    The mouse, and NPRN-specific USB devices devices did not work, when plugged into the Hub, if it's connected to the USB Host Port.  I know that's mentioned in the docs, but worth saying again, as it screwed me up.   Like I said.. with the Amazon hub being used in the USB Host Port of the iCM4+, my old hub was freed up for use, directly into my iMac.
  • ah - glad to see that you are addressing this issue, which is a big one. I had a hub, recommended for general musical use from sweetwater sound, and I've been going through hell with it and the mio10. I had it working for a few days, but now it is not recognized. I'd say avoid it - it is the d-link dub-h7. I have one that is working with my mio4, but the main usb connection is hardwired, and very short. It's a sabrent https://www.amazon.com/gp/product/B00HL7Z46K/ref=oh_aui_search_detailpage?ie=UTF8&psc=1
    i think i saw someone mentioning a sabrent above. can't remember if negatively, but I am having success with this one.
  • you guys should make your own cheap usb hub that is guaranteed to work. I really don't like plopping down $$ with really no idea whether a hub will work or not. and it looks like the sabrent that I mention just above works with some devices and not others!

  • Everything was OK while running Mac Mavericks.
    Hub is  Anker powered 7 ports with 3 charging ports hub. 
    Upgrade OS to High Sierra, hub stopped working. 
    Tried another hub a Satechi passive4 port  hub still not working.

    Seems like High Sierra  & IconMidi4 don't like each other.
    Fix please asap.

     
  • We have tested this here, and for us everything is still working fine after upgrading to High Sierra. We have no idea why it isn't working for you.
Sign In or Register to comment.