iOS 11 connectivity issues

edited September 2017 in Software
iOS 11 public beta 7, iConfig for iOS v4.2.7, ICA4+ firmware 1.1.2

iOS app sees the device, but when selected Device Info is blank. Tapping any other tab gets the "communication lost" dialogue.

Persistent attempts to reconnect eventually, sometimes, get it to work. 

The macOS software reads the device with no problems.


  • I get the same problem with iOS 10.3.3, ICA4+ firmware 1.1.2.

    iConnectivity iConfig (macOS) 4.2.6 works without any apparent problems.

    However, iConnectivity iConfig (iOS) 1.13 and iConfig for Audio (iOS) 4.2.7, are completely unusable. Whatever I do, I get "Communication Lost".
  • Fwiw, in my case the iOS app actually seems to allow the ICA4+ to talk to the iPad via other apps, but the iConfig app itself is useless.
  • Installing iOS 11 beta 9 does not fix any issues.
  • We are getting several reports of this issue happening. But we also have many people using it without a problem. Up to now we haven't been able to figure out why it works fine for some people and not for others. It's really mystifying :-(

    We are continuing to investigate.
  • My ICA4+ worked well on my iPad Pro 9.7 I have moved up to an iPad Pro 10.5 and now the software crashes after finding the ICA4+ when I click on any tab.
    iPad Pro 10.5 using 10.3.3
    ICA4+ using 1.1.2
    MacOS 10.11.6 works fine using iConfig 4.2.6
  • Strangely, connections from the iPad/app to the ICA4+ have become reliable again.

    As far as I can tell, I have not installed new versions of any relevant software. In fact I didn't do anything with the express purpose of solving the communication problem. I did restart the iPad, but I had done that before and it didn't help than.

    I'm a bit concerned that I don't know what caused and later solved my problem, but I'm happy that it's no longer there (for now at least).
  • This shows you why we are having trouble figuring out what the problem is :-)
  • I'm still having this problem, exactly as described, since I went to iOS 11.
  • Are we getting any closer to this? It kinda sucks not being able to change any of my settings with my iPad.
  • Some people are reporting that iOS 11.1 fixes this. Apart from that we are still mystified as to what exactly is causing it.
  • Is Auracle going to replace this app? So what do we do, in the mean time?
  • The first version of Auracle will be MacOS and Windows only.
  • edited December 2017
    Confirming iPad Air, iOS 11.2; neither iConfig or iConfig AUDIO work. "No Devices Found"

    It would be cool if you'd repost the apps so I could check w/ my iPad mini.

    Not a big deal for me as I always have the Mac to do the configuration, but...

    Hopefully we'll see something soon. The iPad option is what sold me on iConnectivity.
  • Hello Mr dancing Good new, i knew the way to fine a issue a the « No device Found ».
    I have fine this way really accidentally.
    First if you have a midi device sucht a keyboard connected in the usb midi port of the iconnect4, just try turn it on and off imediatly after start iconfig app.
    Be patient, if that not run at the first try.
    Double tape on the home button, to close the iconfig app.
    Launch/start the application once again, and simultaneously push the on off button of your midi device.
    For Me after some attempt this technique works, and i have acces to the iconnect4+ and the session is very stable.
    So good luck i very hope that trick work for you as well...
Sign In or Register to comment.