ICM4+ / on MACBOOKPRO / WITH ROLAND FA-06/08 - MAKING IT ALL WORK TOGETHER!! :)

COMPATIBLE USB HUB
 This was my first problem, because we have no way of knowing if we have a bad cable, a defective ICM4+ unit, or if the keyboard isn't setup right, or if something is wrong with the ICM4 box, or if the hub itself isn't working. I tried 3 other hubs and none of them worked... I just returned my last incompatible hub today back to the store. The only hub I saw mentioned on here as working well with ICM4+ - and was easily obtainable - was the Amazon Basics 2.0 hub with 10 ports. This is also the only compatible hub I've seen that can take FULL ADVANTAGE of the 8-USB port capability of ICM4+.

COMPATIBLE USB CABLES
I'm also using high quality USB2.0 cables.. I noticed that some USB cables are thicker than others, my guess is they are shielded... but both the thin & thick ones worked for me. I think it's silly that the device manufacturers aren't developing their musical devices with USB 3.0.. it's getting difficult to find USB 2.0 hubs & cables. They're still out there, but their section on the racks is noticeably smaller than the 3.0 section. What's wrong with these music device manufacturers not keeping up with the times??? smh.  >:(  It makes it harder for everyone, now we have to go find 10 year old hubs & cables to work with our brand new $1,200 beat machine! smh  Anyway....

ICM4+ on MACbook Pro Laptop - incompatible with with Roland FA-08???
Here's where I was REALLY getting screwed up!! The FA-08 wasn't showing up in my (Midi Device) list...  but I wasn't sure if it was supposed to. Some ICM4+ tutorial videos showed the guy TYPING the name of his keyboard in the box, others showed the guy just plugging in his keyboard, and the name popped up! (more confusion). 
But then I realized that the Roland website had a FIRMWARE UPDATE, which made it more compatible with other hardware. So I installed that - and LO & BEHOLD... it showed up in my devices when I connected the FA DIRECTLY to the laptop with USB.
 
It also showed up in ICM4+ if I used MIDI cables.., AND I was able to get MIDI notes to show when I was playing using Pro Tools. I was like OMG.. MY DAW IS RECOGNIZING MY KEYBOARD!!!  WHOOO-HOOOO!!  :-D  So NOW I know that the name DOES pop up in ICM4+ Config when it's working right. 

But USB still wasn't working. Turns out - the FA-08 has a USB driver also!! -_- smh..  So I installed that one also, and BINGO - NOW USB MIDI works and the keyboard name showed up in the ICM4+ USB HOST list. I was like OMG - IT'S IN THERE!! :-0  I've never had to install drivers to get a USB port to work before... but that was the problem. The FA-08 STILL doesn't show up in my MIDI Devices, but that's because it's patching in through the ICM4+, so don't waste days trying to get it to show up in there like I did lol..  it won't. 
The ICM4+ DOES show up in there though, and that's what you are connecting things to. Now that I have everything working well, it would be interesting to see if those other USB hubs will work that I thought were incompatible. They probably would, but it doesn't matter - they still only had 7 ports. I DID keep my 13-port hub though - because it's covered in pretty lights when you plug it in :-D

So there you have it - Mission Accomplished!! 
I hope this can help others get theirs working too - Just LOOK FOR DRIVERS & UPDATES from your synth manufacturer FIRST!! lol...  :-D 

Enjoy your music...
Rob 

Comments

  • Glad you got it all working in the end! 
  • WELP... THAT WAS THEN - THIS IS NOW!! 

    Ok, we'er back to the drawing board.. or possibly even the trash can! As stated previously, I DID get my FA-08 to work with ICM4+... after weeks of struggle! I even got the Integra-7 and it worked as well... BUT, then my FA-08 stopped showing up in the USB Host list. They wouldn't display simultaneously, even though both were plugged in... even if I disconnected the I7.. FA wouldn't display anymore. So I tried updating the drivers for FA and I7... and OH LOOK - ICM4+ has a new firmware update that it's FORCING me to take. So ok, I let it install... reboot... and now I don't see the I7 OR the FA... I'm like WHAT THE FUCKKKK???
Sign In or Register to comment.