Communication Error when downloading new firmware

Just got the Iconnectaudio, but haven't been able to move pass a communication error when downloading the firmware update. Usb's are in the appropriate ports and my computer has recognized the ICA4. I'm running osx 10.10.2

Comments

  • edited April 2015
    Have you tried the update with the hardware in 'bootloader mode'? If you hold down the power button for a couple seconds while plugging in your interface, you will manually put the interface in firmware update mode (yellow LEDs will toggle back-and-forth).

    Once the hardware is in update mode, launch iConfig and choose the interface (you should see 'bootloader' referenced here). Then try the firmware update again - let me know what happens. Make sure you are using device Jack one, which it sounds like you are.

    Let me know if you run into any other troubles,
    -JS
  • The ICA4 is not recognized once I launch 'bootloader mode'. I'm definitely on port 1 and can access the ICA if I skip the firmware update.

    I'm really trying to wrap my head around midi routing and the Audio Patchbay. My initial tests would not allow audio pass through on channels 5/6 as . Is this addressed with the firmware update?
  • You are not able to see the hardware in 'bootloader mode' once the yellow LEDs are toggling back and forth? You will need iConfig to be closed when you perform this, then reopen iConfig to run the update.

    Although, If you continue having trouble getting the computer to see your hardware in bootloader mode, or you are not able to update to latest firmware, please click on my name and send me a message with your contact information. I will have a support tech reach out to you tomorrow to see what's going on.

    Let me know how I can assist further.
    Cheers,
    -JS
  • Steven I was having the same issue. The USB port needs to be connected to port #1 in back of your iconnectivity device.

    At first mine was connected to port #2. Once you do this you should be good to go!
  • I'm definitely in port 1 and I've tried dozens of times to restarting the Iconnectaudio into bootloader mode, but I still can't download the new firmware.

    I've gone into my usb settings via about this mac and can see my ICA recognized.

    When I reset my ICA into bootloader it's not recognized by iconfig. How should I proceed?
  • Steven, can you please try a different USB cable. If connecting through a hub, please try direct connection to computer.

    Let us know.

    Thanks
  • Still no luck, unfortunately.
  • edited May 2015
    We appear to have an issue in some cases with iConfig doing firmware update. We are looking into this now. We have had other support ticket with similar issue which was resolved with a manual update procedure. Please issue a support ticket to get these details.
    http://www.iconnectivity.com/support/

    We will publish a white paper soon with the manual update procedure.
Sign In or Register to comment.