iConfig Firmware Update & Support System Issues

Hi all!

We switched Internet hosting providers and this has broken the firmware download check in iConfig, causing the application to appear to freeze while attempting to download firmware. This hosting change also created a few issues with our support system. 


UPDATE: 4/18/17  We've officially released version 4.2.4 This version addresses the issues of iConfig freezing while trying to update firmware. 4.2.4 removes the automatic update feature. If you are still experiencing the freeze issue you are likely running an earlier version of iConfig. 

If for any reason you are still experiencing a freeze, just hit ESC and it will cancel the the attempted firmware download and iConfig should continue to load. Once iConfig is fully loaded please double check which version you are running.

You can download iConfig 4.2.4 here: 



RE: Support system issues

In addition to the issues with iConfig, the hosting changes resulted links being broken in our support system. If you need to check the status of an open ticket and are getting "page not found" error please go to https://support.iconnectivity.com/view.php to check your ticket's status.

We're very sorry for the inconvenience, please rest assured we're doing everything we can to fix it as soon as possible.

Thanks for your patience!


«1

Comments

  • edited March 2017
    Please note that a public beta version of iConfig that addresses the issue causing the application to freeze while downloading firmware has now been posted. See details in original post above.

    Thanks!
  • Thank you...
    Better late than never iConnectivity, yesterday was a total lost because of this.
  • edited March 2017
    Make sure to remove the previous version before trying to setup the new version 
  • Hi,
    Why not iConfigAudio for iPhone yet?
    iConnectAudio4+ works perfect with iPhone, but can't change config.

    With screen resolutions in the new iPhone's, the iConfigAudio app, can work perfectly and will be usefully.

    Thnkx
  • @Shoroc - If you can turn off your Wifi / unplug your connection, that will allow you to launch iConfig without this issue. (I didn't want to install the beta, so I tried that and it worked.)

    Cheers,
    CK
  • @ckbarlow,

    Thank you for that trouble shoot alternative, I did try that on Monday(last) in my frustration but had no resolve then. I'm running the BETA, seems stable operation "but" every new day the computer power-up I have to relaunch the beta app. Hope Connectivity resolve soon.

    again, Thank you ckbarlow.
  • edited March 2017
    Hi Folks, 

    Here's little update from iConnectivity HQ.

    We've been busily testing the new beta build of iConfig. We expect to have an official release in the coming days. Here are the known issues for the current build.

    1) Changing bit depth and sample rate resets patchbay and mixer routings
    2) iConnectMIDI2+ and iConnectMIDI4+ presets are not properly loading audio settings (but do load MIDI info correctly)

    Thanks again to all for your patience! We'll do our best to keep you updated.
  • iConnectivity should I replace iConnectMIDI4+ with another company's product? I cannot accept not having proper functioning of this midi interface for more than a week now. After all that time to setup this thing!!
  • Shoroc, what are the issues you're having? I'm not making light of your understandable frustration, but you should be able to configure your interface once and use it.
  • just to add.

    the beta doesnt work for me, it also stops when trying to download firmware similar to the official release.
    i'm trying to get the iconnect midi2+ firmware , this file doesnt seem to exist when clicking on the link on the firmware page either.

    the app works when i unplug my network connection , so i think its just updating firmware thats an issue.
    on mac ... latest os .
  • edited April 2017
    Hi Guys,

    You don't need to turn off your network connection to bypass the firmware check. Just hit the ESC key and it will cancel the firmware check if it hangs for some reason. iConfig will then continue to load normally.

  • edited April 2017
    bimbom, could you try to uninstall iConfig completely and then download and reinstall iConfig again? 

    Also, I see the broken link for the iConnectMIDI firmware. Thanks for pointing that out. I've gone ahead and fixed it. That wouldn't be the reason you are having the experience you are having with iConfig though.
  • @ nickbatz / ajoelson

    On March 19th my studio stopped working properly, after trying all sought of troubleshooting including rebooting, resetting, unplugging even visited iConnectivity website because I suspected the issue was iConnectMIDI4+, I was unable to get my Midi gear communicating with the Mac. On March 21st a notice on iConnectivity's website claiming the issue is indeed with iConnectMIDI4+. I downloaded the beta but I still had no luck.
    After my posting I disconnected iConnectMIDI4+ and returned to a conventional Midi Interface which got my studio back on track. I may at some point return to your technology but not right now.

    Thank you.
  • Ah. There's a Firmware Check Frequency setting under the Device menu. Please try turning that off.
  • The application doesn't "appear to freeze", it DOES freeze.  You can't close the update window because the update isn't optional - for whatever stupid fucking reason - and you can't click past/around/behind the update window.  And it's fucked up that you didn't even mention the disable-WiFi workaround, but rather I had to learn about it in the comments from a fellow user.  I was warned that your gear was amateur, I guess I should have listened.
  • proteus, if you've downloaded the latest iConfig, turned off checking for updates, and you're still having issues, please let me know.

    And I don't know what the disable-WiFi workaround is, but I'll do my best to help you or (if I can't) to get help with whatever's going on.

    Other than that, may I request that you take a deep breath before fuming?

    Being a musician with a project studio since the '80s, I'm totally sympathetic to how exquisitely annoying it is when things don't work right. And more than accepting constructive criticism, iConnectivity encourages it. But... but... as an actual user, I find these products pretty darn clever, and your assessment might be a little harsh.
  • Hi, I understand there are issues. Do we have any timeline ? 
    So, we'd be able to plan and possibly change our settings ?
    Yes, I am a completely amateur home recordist. I rely on weekends to make some recordings to send here and there some material. 
    This was really a disappointment. 
    So, please, find a solution. I'n having iConnectAudio4+ and I am otherwise very happy with it. It connects my ipad to my iMac. 
    Does miracles, but this time around....so sorry. 
    Thank you 
    Vesselin 
  • edited April 2017
    Hi proteus_ix & Vesodoc, are you using the latest download of iConfig, version 4.2.4? This version further addresses the issues of iConfig freezing while trying to update firmware. 4.2.4 removes the automatic update feature. If you are still experiencing the freeze issue you are likely running an earlier version of iConfig.

    If for any reason you are still experiencing a freeze, just hit ESC and it will cancel the the attempted download and iConfig should continue to load.
  • iConfig 4.2.0 is the most stable and fastest version for me.
    In my case with a PC with Windows 7 Ultimate 64bit and iConnectAudio4+
  • All new versions take a lot of time to detecting the iConnectAudio4+ .
    The 4.2.0 version detect it instantly.
    I have disable automatic firmware update in settings, because it doesn't work and I don't want to do it every time I run iConfig.
  • I have already downloaded the beta version and the instructions followed exactly as described on your site. My audio interface is an RME Fireface UFX and my DAW is Protools 11.3
    Still no input and output in my Fireface UFX. In Protools comes a MIDI signal into the instrument channel. Playback Engine is on Aggregate Device.
    What to do. Since one month I'm just there to experience any pleasure in owning Iconnectivity MIDI 2.
  • BEARstudio61, could you please describe your issue in a little more detail?

    I'll see whether I can sort it out with you. Does it sound like a MIDI routing problem, i.e. Pro Tools isn't seeing MIDI from your interface?
  • edited April 2017
    Device Iconnectmidi4+

    Hi after update software Iconfig 4.2.4 the new firmware 1.0.7 was downloaded.

    There is a big problem with midi chanel remap, with previous version it worked correctly.
    The problem: when I set midi remaping for one device this doesn't work... (midi chanel is remaped for all devices)

    I  try downloaded older firmware iConnectMIDI4_DFU_105_20160418.mid but I don't know how instal it - some tips? how revert the firmware?

    Why the firmware 1.0.7 does't for downloading directly, is the beta version or what?

    Thank you for answer.

    EDIT:

    edit: finaly i reverted firmware to 1.0.5 - i found the solution on youtube



    it is for iconectaudio but it works for Iconnectmidi4+ too, and everithing works ok

    So the problem is definitely with firmware 1.0.7

  • Wow this needs to be fixed now!  We do tours which the computers needs to be online so this problem is a deal breaker - What is taking so long to fix this problem?
  • @LivSingh are you talking about the firmware timeout issue? If so it has been fixed for some time. We've now changed the release status from beta to standard release. If you are having another issue please let us know by starting a new thread or contacting support.

    Thanks!
  • Hi All,

    A quick update. We've officially released iConfig 4.2.4 This version addresses the issues of iConfig freezing while trying to update firmware. 4.2.4 removes the automatic update feature. If you are still experiencing the freeze issue you are likely running an earlier version of iConfig. 

    If for any reason you are still experiencing a freeze, just hit ESC and it will cancel the the attempted firmware download and iConfig should continue to load. Once iConfig is fully loaded please double check which version you are running.

    You can download iConfig 4.2.4 here: 
  • Two (minor) bugs in iConfig 4.2.4 to report: 
    in the main menu under Help:
    • clicking on Online Help: you get the message: "We couldn't find the page you were looking for (etc.)";
    • clicking on Register: idem dito...
    And why does this iConfig-version need 24 seconds (!) to start up (while doing its "Device selection")? (Prior versions needed only 1 or 2 seconds.... (and I only have 1 device)).. 
  • Midi Patchbay tab is present in the version for the iOS, but not in the version for the desktop. Why?
  • Please use MIDI Port Routing instead.
Sign In or Register to comment.