Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

ICA4+ Communication Error

edited August 2017 in Software
When I connected my ICA4+ to  a new laptop and started iConfig,  I kept getting communication errors.   I tried in three different computers.  I installed a few times the latest driver and the latest version of iConfig.  Installed them all as administrator. 

The firmware is 1.1.0, hardware version is 1.0.   
It connects to my iPad just fine and also works in PC DAWs and VST hosts.
The ICA4+ is recognized by iConnectivity Asio Control Panel in all three computers, but it is just that iConfig can't open and find the ICA4+   


  • edited August 2017
    Manually updated the firmware to the latest.  Still, iConfig doesn't open in my Windows 10.   In my daughter's Mac, iConfig opens and finds the device just fine.  Just to make sure, I deleted some virtual midi drivers.  Still, iConfig doesn't open a midi port and just crashes while all other apps open all the midi ports including the ICA4+   I ran a registry cleaner, but no luck.   I wonder why iConfig can't even find its own device.....     Any suggestions?   
Sign In or Register to comment.