Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

pulling my hair out with iConnectMIDI2+ and Bitwig, need advice please...

edited April 2018 in MIDI
I'm using iConnectMIDI2+ with latest firmware 2.0 updated with Auracle and Bitwig on my iMac. In Audio MIDI setup, it shows DIN1, DIN2, USB1 and none as the ports on the device. In Bitwig, I have a MIDI keyboard device with input set to iConnectMIDI2+ USB 1. Audio passthrough works fine, I can record audio coming in from my iPad. And MIDI coming from my iPad to Bitwig works fine, but I can't get MIDI from Bitwig to my iPad. On my Instrument track in Bitwig, I have a hardware device going out to iConnectMIDI2+ USB 1, but when I go into either Moog Model 15 or Moog Model D, the only available USB MIDI shows up as iConnectMIDI2+ USB 2. I've removed iConfig on both my iPad and my computer and reinstalled them and I restarted my iPad and my iMac but nothing seems to work. I've been messing with this for hours with no luck. 

Anything stand out to try?

thanks for any help.

Greg K.

Comments

  • P.S. I tried going into iConfig on my iPad and changing the name of the port to iConnectMIDI2+ USB 1 but it didn't change the name of the port or the behavior in the instruments on my iPad (Moog Model D or Model 15).

    Also, when I updated the firmware to 2.0 using Auracle, I showed DIN1 had output of DIN2 and DIN2 had output of DIN1. I just left that since it seems to want that as the default but I'm confused about why this is?

    I know there must be a simple answer to all this, but I just got flustered and confused by it!
  • On my Instrument track in Bitwig, I have a hardware device going out to iConnectMIDI2+ USB 1, but when I go into either Moog Model 15 or Moog Model D, the only available USB MIDI shows up as iConnectMIDI2+ USB 2.

    Which USB ports do you have your Mac & iPad plugged into? If you send from Bitwig to iConnectMIDI2+ USB 2 instead does that work?

    I've removed iConfig on both my iPad and my computer and reinstalled them

    If you are using Auracle for configuration there's no need to use iConfig - that's only going to confuse the issue. I suggest just uninstalling iConfig completely in this case.
     
    Also, when I updated the firmware to 2.0 using Auracle, I showed DIN1 had output of DIN2 and DIN2 had output of DIN1. I just left that since it seems to want that as the default but I'm confused about why this is?

    This is the default out of the box setting so that if you start it up without a computer you can attach a keyboard to DIN1 Input and a module to DIN2 Output, and then the keyboard will directly play the module.

    When you are using a DAW like Bitwig Studio you probably don't want them to be directly connected to each other. Instead you'll probably want them connected via the DAW; so you can just turn off the direct connections in the Auracle MIDI page.
Sign In or Register to comment.