Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Noise burst (sync loss?) when iPad comes out of Lock

Using iMaschine as AudioBus Input to System Audio Output.

After iPad coming out of Lock, audio is very bad - much more extreme than 'crackles and pops' a la too-small-buffer. Absolutely hideous, and samples run maybe three times as long in time duration than when things are working. The only way I have found is to disconnect/reconnect the Lightning connection.

I guess the obvious solution is to prohibit the iPad from going into Lock. But is there anything else I should do? Is this proper behavior?

Possibly relevant: the USB B <> Lightning cable that came with my unit does not work (see last night's post). I am instead using the USB B <> 30p that came with my iCM4+ and an Apple-branded 30p <> Lightning adapter.

4th Gen iPad
iOS 8.3

iConfig Mac 4.1.0
HW 1.0
FW 1.0.6

Comments

  • edited May 2015
    Hey Joe,

    Sounds like you have a new iConnectivity cable on the way, which is good news.

    I prefer to take the lock feature off through iOS preferences when using apps. Also, have you tried using a different bit/sample rate? Some iOS apps preferred to work 44.1/16bit, especially when using multiple apps together.

    Let me know if that has any affect on your drop outs/bit distortion,
    -JS
  • Yes, as I mentioned, it happens after coming out of Lock. Preventing Lock via the DoNotDisturb seems to have solved the issue, but this seems suboptimal. Why is sync not reestablished? Is this 'just the way it is'?

    I am still at the default 44.1k/16 rate. I've not yet had a chance to change, with the expected pain that may entail.
  • When the iOS device goes to sleep the hardware can get confused as to what kind of computing device is connected. That is why I would recommend taking autolock off while using music apps.
Sign In or Register to comment.