Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

How connect 2 or more USB keyboards to Audio²

So far I use a Novation Ultranova via midi in/out and an Ipad on the backside Ipad USB and everything works fine.

Now I got an AKAI MPK261 which I want to use as Masterkeyboard in Cubase.
I read about USB hubs on the Audio4 but I am not sure wether it addresses exactly what I need and is working on the Audio² as well.

So can I use an USB Hub on the Ipad USB connector on the back and thus connect multiple USB Midi Instruments/Keyboards or will they all be palying parallel?
Or should I daisy chain the two keyboards?
As the Ultranova has USB as well, can I use is on an USB hub together with the IPAd in parallel on different Midi Channels and connect the Akai via Midi connector?
Also I have not used the PCMAc USB on the back and use the PCMac/Power connector towards cubase/PC. Can those somehow be used in parallel?

Comments

  • edited June 2018
    can I use an USB Hub on the Ipad USB connector on the back and thus connect multiple USB Midi Instruments/Keyboards

    No, that functionality is not available on the AUDIO2+. You will need to either go up to an AUDIO4+ or add another MIDI interface that does have the USB Host port capability, such as the mio4.


  • Thank you. Is there a way to use the Audio² and the Mio4 in parallel on a daw? Or will I have to buy a separate Audio interface then as well? Does the wifi option on the mio include midi connection of Ipad/Iphone?
  • And sorry, the mio 10 does not have the wifi option? Many questions I know. JUst to be sure this time which interface I have to get.
  •  Is there a way to use the Audio² and the Mio4 in parallel on a daw?

    Sure, just plug them in.

    Does the wifi option on the mio include midi connection of Ipad/Iphone?

    There is no built-in wifi on the mio4 or mio10, however there is Ethernet, so you can connect the interface to your router via a Ethernet cable, then connect your iOS device to the router via wifi. That should work fine.
  • Sounds perfect, so I order the Mio4 now at Thomann 
  • Now I have the mio and at first sight seems to work. Only several issues... :)
    Connections are as follows:
    Audio² has Ultranova Midi in/out the Ultranova and Audio in Ultranova as well, plus the Ipad on left side USB port with PC connected on Power/USB. Speakers connected form headphones out.
    Mio is connected via front USB to PC and the left USB on the back is connected to Akai MPK2.


    Issues:

    1) When Mio4 is connected to PC, then Cubase won´t find the Audio In coming from Audio² while Audio still works from Cubase outwoards and Audio from Ultranova or Ipad as well. Settings in patchbay are unchanged from before working settings.

    2) While mio3 appears in Cubase together with a list of ports, neither selection of port will make the Akai MPK261 work on any selected track other than on "All Midi in". Mio is still set with factory settings and no changes.

    Hope there is a simple explanation to solve these issues.
    1. Which Windows driver are you using? The latest unified driver? If so, ensure any older drivers have been removed.
    2. Is there any reason why you are using iConfig instead of Auracle? Auracle should just route all this stuff correctly automatically
  • 1) did not install the usb, being afraid things will get worse :)
    2) Tried Auracle, did not seem to work, but I can retry.
  • New usb installed, solved the mio4 problem.
    Got me a new problem though:
    At startup of Iconnect it goes straight to the MIo4, no switching of devices possible
    Still no sound on USB1 in Cubase. Since I have no acces ti Audio² settings, How do I solve this?
  • edited June 2018
    now with auracle midi routing seems to work fine.  While windows seems to work with iconnectivity audio cubase does not load the Iconnectivity Asio settings. While I can choose it from the list it jumps back to Asio Direct X Full duplex Driver. So no audio in from Audio² in Cubase. The Duplex Asio can be connected to Audio in at Cubase, but still no Audio coming in via the Host Port of the Audio² towards Cubase.
  • I'm baffled as to why Cubase won't connect to the iConnectivity ASIO driver, that should be the easiest thing in the world. I don't have a copy of Cubase on this machine to check right now, but it works happily with everything else I have thrown at it. Can you open the iConnectivity ASIO Control Panel and see the interface there ok?

    You may need to contact Steinberg and see if it's a known Cubase issue. I can't imagine it is though.

    Glad everything else is getting sorted so far!
  • Did post in a cubase help group on FB as well

  • edited June 2018
    Just to try something different, I disconnected Mio4 to be able to enter Iconfig. Won´t load anymore since auracle had been installed.
    Should the front Audio and USB Audio from Ipad not be automatically routed to host PC USB? I there a way to doublecheck if this is the case by using something other than cubase? So if your device sends audio via USB PC then I can go on locating the problem in Cubase. If not we go ahead searching on iconnectivity side. Solution for checking this? An easy check for beginners in Ableton maybe?
  • I disconnected Mio4 to be able to enter Iconfig. Won´t load anymore since auracle had been installed.

    I have no idea how that could be. We run both apps side by side on all our machines all the time (this isn't really recommended BTW, since they have completely different ways of approaching routing).

    Should the front Audio and USB Audio from Ipad not be automatically routed to host PC USB?

    See the section on Using 2 Computers with Auracle in the Auracle User Guide for details on how Auracle routes this.
  • Somehow I managed to get audio signal from input 1+2 into the DAW, but there seems to be no way to get the audio signal from the Ipad into cubase, as if it is not existing. Seems as if Auracle does not send a mix to the Daw but something else.
    The same I had with Iconfig. To be able to register Audio from the Ipad I would have to patch it differently than when I wanted to record Aurio from the front side audio in.
    Is there a setting or way that I can get both signals at the same time sent towards PC? Auracle manual is not really helpfull in that dírection.
  • Sound input seems active, but nothing coming from 3+4. But still nothing coming in. Setting seems ok doesn´t it?


  • Looks right. I don't have a copy of Cubase here to test at the moment, but I just quickly tested this with PreSonus Studio One and the Audio4+ sitting on my desk and it's working fine with that setup. I will get a better test set up later for you.
  • Retested with an Audio2+ and apparently the manual is wrong - your should should come from Input 5&6 not Inputs 3&4. Please try that!

    I will update the User Guide now to reflect this :-)
  • Finally everything is working perfectly. Thank you for your consistent support!
  • Thank you for your patience! Glad to hear it's all working out!
Sign In or Register to comment.