Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Mio 10 -> USB -> RJ45 -> USB keyboard issue

I have made the following connection:

Iconnectivity Mio 10

↓ 

Usb 2.0 [Male -> Female]

↓ 

USB to RJ45 adaptor

Link: https://www.ebay.de/itm/USB-UTP-Extender-%C3%9Cber-Single-RJ45-Ethernet-CAT5e-Kabel-Bis-Zu-50M-150FT/382794141306

↓ 

USB 3.0 Hub

Link: https://www.ebay.de/itm/4-7-Port-USB-3-0-Super-Speed-USB-HUB-Kabel-Verteiler-USB-2-0-kompatibel-Adapter/264091624072

↓ 

Arturia KeyStep

Link: https://www.arturia.com/keystep/overview

 

Explanation:

I´m able to power the Arturia KeyStep from this setup, but not send back midi data over USB to my Iconnectivity Mio 10


my thoughs:

The first cable downgrades the USB connection to 2.0 and i´m unsure if the RJ45 is 3.0 or 2.0. I could imagine that the connection require fully USB 3.0?

Comments

  • Several issues here:

    USB to RJ45 adaptor

    There's a reason USB cables are as short as they are. USB is not supported over long cable runs. Using one of these RJ45 lines is a hack that is unsupported.

    The first cable downgrades the USB connection to 2.0 

    There's no "downgrading" involved. It shouldn't make any difference what type of USB signal is being sent. If the hub  is supposed to handle USB 3.0, then it should be backwards compatible to any previous version. The mio actually only uses USB 1.0, because MIDI is a really low bandwidth signal.

    I'd suggest you first try it without that RJ45 adaptor cable and see if that works. If it does, then you know it's the adapter cable.

    If you need a long cable run, then my advice is to use RTP-MIDI over Ethernet and forget USB completely.
  • Hi Rodney,

    thanks for your reply and enlighten me.

    I thought that the RJ45, could be a workaround for the cable length issue of USB. Because my desktop is not very close to the Mio 10 and I would like to use this USB Hub because I like the on/off features on the individual USB outputs :smile:

     

    The direct connection without the RJ45 works fine also with the USB hub.

  • The direct connection without the RJ45 works fine also with the USB hub.

    As I suspected. It's that RJ45 adaptor cable. Those things suck.

    If you need a long cable run, the only guaranteed way you can do it is to use 2 iConnectivity interfaces with Ethernet. That works great and you can run it up to 100 metres without any problem. Dump the RJ45 cable and buy a mio4 instead. That's the setup I have right here in my studio and it works great.
Sign In or Register to comment.