Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Launchpad with MIO and RTP

Hi,

could someone point me towards instructions for getting a Launchpad working with the MIO4 and RTP MIDI? I want to plug a current generation Launchpad into the USB port of the MIO4 to use via CAT5 RTP MIDI with a MacBook and PA12 side of stage. The PA12 and MIO4 are linked and I am receiving MIDI from stage but the control script with the Launchpad is not currently working.

Has anyone got this working?

cheers

Archie

Comments

  • I have tried plugging the MIO directly into the Mac and the Launchpad appears and works using the control script. I just can't get it to work over RTP MIDI. Any help much appreciated!
  • To clarify, when I say not working - the computer is receiving MIDI over RTP but the launchpad won't light up and I am unable to change into the user mode or use any of the normal functionality.
  • The Launchpad's USB-MIDI implementation is not fully class compliant, so things like the lights and the other stuff you mention won't work. The only way to get full USB functionality is to plug it directly into your MacBook.

    However if you do that, you should be able to route its MIDI via your DAW to the PA12 via a USB-DAW connection and/or to the mio4 via Ethernet. You just won't get redundancy if you are using 2 MacBooks.

    https://iconnectivity.supportbee.com/53-iconnectivity-knowledgebase/534-midi/837-is-my-midi-device-compatible-with-the-iconnectivity-usb-midi-host-port
  • Thank you Rodney. That's a shame. I also tried using a Kenton USB/MIDI converter and plugging in and out of the MIO on a DIN port but have the same issue - it works fine if the MIO is plugged into the Mac but won't behave over RTP via the PA12.

    I think we will return the Launchpad as there's no practical way to plug it directly into the laptop in our setup. 

    Cheers

    Archie
Sign In or Register to comment.