Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

RTP-MIDI, Auracle and iConfig - how I finally got it working (and Auracle feature requests)

I have been struggling to use the RTP-MIDI manager to connect my iCM4+ and mio10 together. Sent two support tickets but the answers did not solve the problem. I finally sorted out it (fingers crossed). Thought I'd share my experience as it could help others as well as give some feedback to iConnectivity.

I had been using iConfig instead of Auracle to configure everything as my complex setup needs filtering and channel remapping. When using Auracle to set up RTP-MIDI connections between the two interfaces, I kept on getting errors that the interfaces were not on the network. This persisted no matter what network configuration I used (static or dynamic IP assignment etc). I tried multiple Ethernet switches, routers, cables to no avail.

Whenever I opened Auracle I also got a cryptic message that my interfaces used a non-standard configuration and whether I wanted to reset them to default. Because my setup is dependent on advanced iConfig features (filtering and re-mapping) I kept on saying no. 

But eventually I bit the bullet, saved everything in iConfig as Presets, made notes of all my configuration, then reset both interfaces to factory defaults and tried again.

When I used iConfig to reset to factory defaults, I still got the errors, and RTP-MIDI manager still did not recognise the interfaces were on the network.

However when I did a full reset/factory defaults with Auracle, it finally worked and I was able to make the RTP-MIDI connections within Auracle. Great stuff!

I then manually re-entered all my routing info using Auracle since Auracle won't read iConfig preset files. I still needed the filtering/re-mapping so was able to add that using iConfig, on top of the Auracle-programmed routing. Auracle did not complain.

However I also needed to change the default routing of the USB device ports on the mio10 so my DAW could access some modules directly. This was not possible in Auracle, which uses a standardised routing where HST5-10 are all connected to the same device port. So I did it in iConfig. Now every time I open to mio configuration in Auracle I get the error that the mio10's configuration is not standard and whether I want to reset it to default. But RTP-MIDI is still working!

So lessons are:
  • some iConfig configurations will mess up Auracle's RTP-MIDI manager (with a misleading error message). Only a reset to factory defaults using Auracle was able to fix this.
  • Auracle does not like it when you change its default USB device port routing. This is annoying, I'd like to be able to configure my USB device ports using Auracle and not just use the default routing, which is not good for the mio10 as it has more DIN/HST/ETH ports than are available on a device port.
  • It is possible to use Auracle for the basic functions then do the complex routing in iConfig on top of the Auracle routing
  • Auracle and iConfig seem to store the port name information in a different way. I had to rename a number of ports in iConfig so the port names show up in my DAW correctly on my Mac. The Auracle names were uninformative.
  • Very annoying not be able to save presets/configurations in Auracle like you can in iConfig. It would be even better if Auracle and iConfig could read each other's preset files.
  • It would be great to be able to export a graphical representation of a routing/filtering configuration. It would make it easier to debug issues and move a configurations between iConfig and Auracle.
Sign In or Register to comment.