Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

iConnectAUDIO4+ outputs stop playing audio and play electronic noise

Hi everybody!
While I'm waiting for iConnectivity support reply, I'd like to share a problem I've been experiencing for a while:
all iConnectAUDIO4+ outputs stop playing audio and play high level electronic noise; iConfig works normally except for audio meters, which don't display anything even if audio softwares keep running as if nothing happened.

Everything else is working properly: ICA4+ front panel controls, iConfig and iConfig controls, all softwares keep running (I didn't have a chance to check midi during these events).

The problem was present while firmware on 2.0.3.
Issue was happening only seldom and in the last year I've been using ICA4+ only at home, so it wasn't bothering me enough to investigate further: I power-cycled the soundcard and went on working.
In the last weeks the problem started becoming more frequent. Hardware or software configuration hasn't changed or moved (I do my live-sound work with AUDIO2+), so I tried connecting the audio interface straight to computer (before was through an USB 3.0 hub).
Still getting the noise every once in a while and needing to reboot the AUDIO4+, yesterday morning I tried updating to 2.0.5 and the issue is showing more frequently.
I cannot track the problem to a specific software nor duplicate the behaviour on purpose.

Unpatching everything from analog outputs on iConfig doesn't stop the noise, which is present on all outputs, and its level responds to volume and mute controls for every channel.

Power-cycling the unit restores the normal working condition.

Only iTunes running. It happens again, and again.
Tried also resetting card to factory settings, but issue manifests anyway.

Tried changing audio frequency and bitrate, USB cable, USB port, computer...

Any idea?

Thanks, regards
G
Sign In or Register to comment.