MioXM - native USB drivers not being run when running through USB Host

Hello everyone, 

I have a MioXM connected to my laptop, DAW is Studio One 4.6 Professional. I have a Roland Fantom 7 and a Korg Kronos 2.  I have no problems at all with the kronos, it happily gives and takes all the midi I can send it from my daw. The Fantom however is more problematic - in host mode, the the native drivers I installed on my pc do not activate, as the MioXM is viewed as the USB Midi connection. I connect the Fantom directly to my PC and the native drivers launch. Is there a way around this?  I have resorted to using the DIN ports on the MioXM, and I can record midi from the Fantom to my DAW.

However, regardless of whether I use USB Host, or DIN, I can't for the life of me get the fantom to play back the midi notes I'm sending it from my DAW. Is there something I'm setting up wrong in the MioXM?  Could someone please walk me through what the settings should be?  I have looked through all available documentation, and can not seem to find any answers.

Thanks so much in advance, 

IvoryStrat

Comments

  • The USB-A host ports on the mioXM will only accept USB class compliant gear sending MIDI data only. Roland often has drivers, which you've mentioned making it not class compliant and therefore not allowing it to work in the host port.
    The Roland should, however, work in the DIN ports to send MIDI data. 
    Please verify you have the following connections made.
    Port end labelled MIDI IN is connected to MIDI OUT port on your external hardware ( Fantom).
    Port end labelled MIDI OUT is connected to MIDI IN port on your external hardware.
    Then I would look at what DIn it's connected to and how you are connecting the mioXM, USB DAW or RTP?
  • Thanks so much for the response @tsho08 .  I can confirm that MIDI IN is connected to MIDI OUT and vice-versa from Fantom to MioXM.  I am connecting mioXM via the USB DAW port, to a powered USB HUB, which in turn is connected to my PC.  Let me know what else I can give you information wise, and I'm happy to provide.

    Thanks again.
  • I guess my thoughts are what do you need the fantom drivers for? Are you trying to connect to a specific piece of software from Roland? Is MIDI going into your DAW from this at all?
    The default routing on the mioXM will say the DIN port names and all you have to do is send to that name.
    It's possible there is a setting in the hardwae that will need to be modified for use from USB to the DIN ports.  Also some pieces of gear have it set where it's only playing with local control and doesn't accept external so watch that.

Sign In or Register to comment.