Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Mixed first impressions

Hello all,
Two days ago I bought an iConnectAudio4+ and since then I'm trying to 'make it my own' with a simple setup: PC (Windows 7) + iPad (Air) + amplifier and loudspeakers. First I connected the iCA4+ Line Out 1 + 2 to my amplifier, the PC to USB 1 of the iCA4+, the iPad to USB 2, an Akai LPK keyboard to the USB Host and a DIN-midi-Out-cable from my Roland A-500-keyboard (which is also connected to another USB port of my PC, because it is in 'Advanced mode') to the DIN-midi-In of the iCA4+. Then I downloaded and installed the iCA4+-Windows-(asio)driver and after a reboot of the PC I made iCA4+ the 'default' Windows audio-device. Till then everything worked well! With the touchdisplay of the iCA4+ I managed to turn the volume on for output 1 + 2 (to my amplifier) and I could hear 'audio' from PC-software and from iPad-synths (which I could play with the Roland and/or the Akai). So far so good.

Then I downloaded and installed the iConfig-software. And the fun ended (the fact that this software needs the Windows C++-redistributable made me already suspicious, because I have very bad experiences with other software that needed that (lazy programming?)). After launching iConfig it asked if I wanted to update the firmware; 'Yes' was my answer of course, but next a dialog showed "Download complete. Rebooting to bootloader mode." for about 20 minutes (!!!) and then I had to conclude that this procedure was 'hanging' and I had to end it with Windows Taskmanager. Rebooted and all was well and next time starting iConfig I refused the firmware-update and delved in the (for me very complex) mixer- and routing-settings, changed names of devices, disabled midi-ports (HTS2 tm 8) that I don't use, etc.; saved as preset and committed changes to the iCA4+. I experimented with my DAWs Reaper and Cubase, viewed all iConnectivity-videos, had to change the (default) iConfig-routing to record my iPad in these DAWs (after which that worked) and then I tried a firmware-update again: no luck and 'hanging' forever and had to kill iConfig again and after reboot I lost all my iConfig-changes and read the 'Manual firmware-update whitepaper', but that felt like rocket-science and I refuse to go that way.

So I am stuck with fIrmware 1.05...?

Questions and suggestions:
- iConfig seems to be responsible for failing firmware-updates; please find this bug and update;
- I disabled several midi-ports in iConfig, but they stay visible in my DAWs and iPad-Apps; is that intentional?
- I renamed my USB-devices in iConfig, but these new names aren't used anywhere else...

Thank you.

Comments

  • Haropus - sorry about the issue updating firmware. We have had some users unable to do automatic update of firmware and have been trying to reproduce the issue to resolve. In meantime, we have provided instructions for Manual Firmware Update procedure. You can download MIDI file from our downloads page with latest iConnectAUDIO4+ firmware and use the instructions to update your unit.

    http://www.iconnectivity.com/WP-iCA4ManualFWUpdate

    Sorry for the inconvenience and thank you for your patience as we resolve these issues.
Sign In or Register to comment.