iConfig 4.10 trouble

Hello iConnectivity team, I keep having trouble with iConfig (4.10) for my iConnectAudio4+ on a Windows 7 64bit PC:
a. the automatic firmware updates from 1.06 to 1.07 and from 1.07 to 1.08) failed;
b. loading presets don't work.
Ad a.
The automatic update procedure freezes in the dialog "Download complete. Rebooting to bootloader mode."; the iCA is connected to the PC via device port 1 and the internet (wifi) connection is (very) good. The iCA comes and stays in bootloader mode and the yellow leds are blinking. I have to use Windows Taskmanager to shut iConfig down and have to reboot the iCA. The update fails... (and I now have updated (again, this time to firmware 1.08) manually with Midi-OX.)
Ad b.
I have saved two presets before and that went well. But when I open the Load Preset dialog to open a preset and select a preset, then the dialog freezes (becomes light gray and unresponsive) and I have to use Windows Taskmanager to shut iConfig down (and of course the preset isn't loaded).

NB. in june, after I bought the iCA, I installed iConfig 4.10 (after downloading the file iConfigVer4-1-0.exe from your website), but in the About-dialog of iConfig (via Help -> About) it says: version:4.06. That's a mistake I guess...

Should I reinstall iConfig? And if so, should I first uninstall and will I loose my presets?

Comments

  • edited July 2015
    Hello, first can you make sure that previous versions of iConfig are deleted, and then grab the latest version from the website:
    http://www.iconnectivity.com/iconnectaudio4plus-software-driver

    So you know, you can have multiple versions of iCnfig on your computer, so if you are not manually replacing the application it is possible to run the older version still (which is why you are not seeing the latest version in the about section after installing the latest version. So to avoid opening older versions, make sure to drag the application to the same spot and replace it when updating.

    Also, if you continue having trouble updating your firmware you can use the manual update process described here:
    http://www.iconnectivity.com/WP-iCA4ManualFWUpdate

    If you continue having trouble with firmware updates or iConfig crashes, please create a support ticket for us so that we have all of your details document here:
    http://www.iconnectivity.com/support
    That way one of our techs can try to re-create it in-house.

    Let me know how I can assist you further.
    Cheers!
  • edited July 2015
    Hello @jsandeen, Of course I did not replace iConfig manually; I updated the firmware maually. The iConfig version that I'm running is version 4.10 (filedate 5-5-2015) and I noticed a mistake in the About-box (Help -> About) where it reads "version:4.06". That's no problem of course, but it's confusing (have you checked that yourself?). I will create a support ticket for the bugs I mentioned (ie. ad a. en ad b in my previous post).
  • Hello, iConfig has recently been updated for both Mac and Windows - get the new loads here: http://www.iconnectivity.com/support/downloads
  • Thank you @MikeL, loading presets works fine now!
  • Where oh where is the iOS version of iConfig for iCA4+ ??????? It's been 3 months since JS created the "it's a priority" thread................................................I didnt pay good money to sit in a room and wait endlessly.
    My iCA4+ has been on the shelf waiting for the support which should have been there when the product shipped, not to mention basic bugs which literally drove me nuts until I realised I was on my own and gave up. After failing to get a solution via your support tickets I've reverted to using RME with a laptop and not a bug to be found.
    Seems to me you guys have relied too heavily on external expertise rather than rolling your own products entirely in-house.
  • edited July 2015
    Hey @diggo - We'lll handle that question/concern here:
    http://iconnectivity.com/vanilla-forum/discussion/159/is-there-a-release-date-for-updating-iconfig-on-ios-to-add-iconnectaudio4-support
    (No need to post about it in multiple threads).
    There is still no release day at this time. Very sorry for the wait, but it wasn't as simple as an update - software needed some bigger improvement to handle all the extra features that are rolling out as we uodate iConfig and our firmware. Although, it will be worth the wait for sure. Currently testing, so you know.

    I'll let you know anything I hear in the other thread.

    Thanks for all your contributions on the forum - much appreciated!
    -JS
  • Hi JS
    "Currently testing" is sufficient to keep me optimistic - thanks!
Sign In or Register to comment.