Any luck with iOS9?



  • Ok, I'll wait another minute :)
  • I'm also having the same issues, but not in all apps:
    - Samplr clicks and pops all the time. Unfortunately that's the iOS app i use the most!
    - Loopy HD also clicks quite a bit, but less than Samplr
    - iMaschine completely ignores the interface (but it sucks anyway - sometimes it ignores the headphone jack too)
    - Novation Launchpad, Figure, Beatmaker 2, Korg Gadget and Animoog work fine.

    I'm noticing a pattern here: any apps that do real time, full-duplex recording and playing are having issues, so I'd say it's a playback/record clock sync issue. Apps that only play audio are all fine.
  • By the way: I'm running iOS 9. I actually downloaded the update hoping it would fix the issue, but no luck here.
  • Update after reading the forum: setting the iOS port as clock source solved all clicking/popping issues here! I'm not sure it will create other issues on the computer side; I'll try a few experiments and see how things go.
  • So iOS 9.1 didn't solve it. That's too bad. Thanks for letting us know, fzero.

    You aren't the f-ere...etc. I know from DAW-Mac by any chance, are you?
  • I just got the iCA4 a week ago and was having the same exact pop and latency issues in Ableton on my laptop. I was able to solve them by setting the "Clock source" to "USB Port 1 Clock".

    However, now that I'm trying to use my laptop and my iPad Air at the same time, I'm getting those pops from the signal coming out of the Air.

    Hadn't considered that the problem might be iOS 9 and El Capitan.
  • Latency? That's something else, jeremy.
  • I just got the Audio 4+ and to my disappointment I can't use it in the way I bought it for: routing audio from Live into the Ipad to use external effects. I can confirm what iConnectivity stated on El Capitan and Ios9 (which I saw now after the purchase). I get clicks and pops, and it seems to come from a. setting the clock source to anything else than the Mac USB port and b. 44.1 khz audio. or c. both.

    I have tested using a Mac (El Capitan) on USB 2 and an Ipad Air (ios 9,1). on USB 1. On the Mac I run Ableton.
    I'm trying very basic stuff, like playing a Sine tone from Operator synth on a MIDI track.
    1. Setting clock to anything else than USB 2 (the Mac) results on pops and clicks. Buffer size in Ableton does not affect. This is within Ableton, without routing anything to the Ipad. So setting clock to IOS is not an option for me.
    2. Then routing the signal to Audiobus on the Ipad and back again into Ableton. 44,1 khz audio gives clicks in different intervals depending on the buffer size in Ableton. 48 khz and 96 khz routes the audio cleanly though.
    3. Effects like Echo pad or Jamup XT does not work with 48 or 96 khz though. They report Error in Audiobus. I can use 44,1 of course but then I get the clicks.

    So the sound card seems fine for a lot of things, but not using it this way. Maybe, iConnectivity should put a warning sign on their site that it's not compatible with recent operating systems 100% until this is resolved (if ever)?

  • Christian, please read the blog post on iOS 9 compatibility. There are some Apple issues with workarounds.

    I'd paste the link but I'm on an iPhone.
  • Thanks Nick. I have read it and it and it seems to enforce what I'm experiencing. Mac needs to be clock master, otherwise clicks. 44.1 khz audio comes with clicks as well but it is the only type that can be used when using effects in Audiobus.
    It seems Audio 4+ as of now cannot do a lot of what it's main selling point is? Routing audio from a mac through an Ipad and back again?
    I would happily downgrade my ipad to ios 8 to see if that solves anything but it's not possible anymore without jailbreak.
    I hope you soon find a solution to this as Audio 4+ is an intriguing device, albeit not really working as it's said?


  • The interface needs to be the master.

    Do you have El Capitan on the Mac?
  • And while I do sympathize, please understand that this is everyone, not just iConnectivity! iOS 9 and El Capitan created some issues.
  • edited November 2015
    I can't have the interface as the master - this produces clicking audio in Ableton no matter the buffer size.

    I understand the situation.
  • I'm out of town for another 1-1/2 weeks and can't test this until I'm back in my studio, but thanks for the heads-up.

    There's no rational reason Live would be any different from anything else, but then this is software and what makes sense doesn't always matter. :) We'll take a look at this.
  • Have you had a chance to test this, Nick? I'm having lots of problems using iCM4+ with iOS 9.1 and El Capitan 10.11.1. In my case, the DAW is Logic Pro X.
  • edited November 2015
    Unfortunately I have nothing to add to what it says in the blog post, kgmessier. If you have two iOS 9/El Cap devices, make the interface the clock master. And there's no problem running at 48 or 96kHz; it's only 44.1/88.2.

    It occurs to me that I can't test it here without putting El Capitan on my Mac anyway, and obviously I don't want to rock that boat right now!

    I truly wish I had a solution, but alas.
  • Thanks, Nick. So where should I be setting the sample rate if I want to run at 48/96?
  • edited November 2015
    Running iOS 9 on my 1st gen mini and Iphone6 with no issues. Typically I'm using Audiobus, Jamup, Korg Module, iConfig, GarageBand
  • kgmessie: normally in your DAW, and the interface should follow. But there's a setting in the Audio Configuration screen in iConfig (it's under Audio Information), and there may be a preference in whatever app you're running on your iPad.
  • Does anyone at iConnectivity have an estimate when iCM4+ will work with El Capitan and iOS 9 (without having to switch to 48/96 kHz)?
  • I can neither conform nor deny, bla bla bla, but I'm confident you won't share our frustration for long.
  • Then I remain guardedly optimistic. :)
  • I can confirm that I am still getting pops and clicks using Loopy HD and Cubasis in 9.2.
  • Yeah, there's no fix in today's iOS or El Capitan releases yet. But don't read anything into that, please.
  • edited December 2015
    I set the master clock to the USB port that my iPad is in, but I'm still getting latency on Yosemite, all my iOS FX are useless. and I haven't even tried automating and running sequencers in synths yet. has any sort of progress been achieved in the three months since this was reported? are you effectively saying that this issue with iOS9 affects all other audio interfaces with Lightning connectivity?
  • Alex, you shouldn't be having any latency issues. Please file a support ticket.

    Wherever problems you're experiencing have nothing to do with this.
  • Getting closer to a solution, Nick?
  • We don't have a new announcement, but please keep the faith.
  • edited December 2015
    I'm getting the pops now on Yosemite. so many bug reports, ugh
  • I'd be happy to try and help troubleshoot your issues, Alex, but grotesque latency and pops have absolutely nothing to do with Yosemite.
Sign In or Register to comment.