Trying to route audio from internal audio source to record web audio

I'm trying to tap into audio from the web browser so that I can record and sample directly into Live 9. I've done it before but have gotten lost on how best to do it and to do it so that it is on a separate pair of inputs to avoid feedback, etc. Any ideas? Not sure how to see internal audio show up as sources.

Comments

  • Mac or Windows?

    If it's Mac I'd suggest using Soundflower (from the cycling'74 website). It appears to the OS as another audio interface, so you'd aggregate it with the iConnectAUDIO4+.

    Are you using two computer devices? There are other ways as well.
  • edited October 2015
    I have Soundflower. But I have to setup Abelton Live to run everything in through iConnectAUDIO4+. So I'm not sure how I setup and pipe in Soundflower into mixer/patchbay. I think that is how it would have to work right? on a Mac here.
  • So you need to record audio from a browser into Live... but at the same time you want to monitor Live and the audio, right?

    Are you routing the audio anywhere other than your monitors?
  • That's correct. I'm only routing audio out to monitors and headphones.
  • edited October 2015
    Why not use your second usb-audio-device (f.e. with an iPad connected) and run a browser there and record from there in Live? I do it that way, because I'm on a PC with Windows...
  • Yeah, but I was hoping I can just tap into the audio internally rather than affix another device. There must be a way.
  • There is, and it's really easy. Sorry for not answering yesterday, and now that I spent three seconds thinking about it, I feel really stupid.

    Let's assume your Mac is in Device jack 2 and your speakers are in analog outs 1&2. And let's assume you're starting with the default setup to keep it simple.

    1. In the Mac Sound System pref, route your system audio to the iConnectAUIDIO4+ (rather than, say, the internal Mac speakers). That puts it in USB 2 outs 1&2.

    2. Go to the Audio Patchbay in iConfig. Just route the USB 2 outs 1&2 from the Source column to USB inputs 3&4 in the Destination row. (Don't remove the existing connection.)

    3. In Live, arm a stereo pair of tracks with USB inputs 3&4 as the input. But mute their outputs; you don't want to route the system audio to your speakers twice.

    If you need to monitor Live independently of your speakers while you're doing this, I'd suggest routing it to your headphones. Let me know if you need help with that, but I'm confident you'll figure it out.

    You may find this blog post useful: http://www.iconnectivity.com/blog/wrapping-your-head-around-audio-mixer-iconnectaudio4
  • Hello @nickbatz, what do you mean ad 2. "Don't remove the existing connection"? When I follow your instructions I always (per definition) loose the connection Analog I/O 3 + 4 to Destination 3 + 4. Correct?
  • Nick that is great but I'm still getting very mixed up on how Abelton should be setup in coordination with Audio patchbay. I'm getting feedback which means I'm close but I can't get the signal to send to my headphones properly with Abelton and Audio Patchbay. Yes I need help! What should my settings be? Very close to getting this!!
  • The key seems to be assigning "Audio To" in Abelton to something other than "Master". I've got it to work but I still don't fully understand it!! If someday you could make a tutorial that shows all 4 analog inputs used plus audio from computer, etc. AND show how the Audio Patchbay and Abelton are set that would be magic! I have screen shots of what I have done (still can't assign Abelton's CUE OUT properly. Can I attach screen shots to help?? Thanks!!
  • edited October 2015
    Okay, here's the big picture of what's going on. Stop me if I'm not making sense. :)

    You're just using the Audio Patchbay to Y the Mac audio headed for your speakers (via USB 2 outs 1&2) to USB 2 ins 3&4.

    Now your Live track is listening to USB 2 ins 3&4. So far so good - you got this far.

    Now, the reason you're hearing the signal twice is that you've Y-ed it. (It's not feeding back in a loop, it's going to your speakers twice.)

    To solve that problem, make sure the output of the Mac audio's track in Live isn't headed to your speakers.

    The reason you can't just sever the Mac audio -> speakers connection is that... then you'd be severing everything going to the speakers. :) My brain may be twisted, but actually you could use a different USB output pair, say 5&6, to go from Live to the analog outs with your speakers. That's another solution.

    Simple, right?

    hahaha


  • Thanks Nick, I have the routing working now. Jsut moving onto the USB noise issue on the other thread.
Sign In or Register to comment.