Firmware 1.1.0

Hi, I can't find any info on the site however when I switched on today I was asked to upgrade to firmware 1.1.0.

Unfortunately it crashes every time I try to upgrade. Any update available on this ?


  • edited April 2016
    I am in the same quandry. In my case, I had not used the ICA4+ in several months, and was trying to get rolling again, and I was also asked when opening iConfig on Windows if I wanted to update to 1.1.0 firmware. I was very surprised when I got to this forum and could see no mention of it except for this one post from this morning. And yes, it says download complete, puts the ICA4+ in bootloader mode, yellow lights flashing on box, then nothing. Restarted computer. Won't try that again til I learn more, and will only post back later if I can't get box to work anymore...
  • Yes my ICA4+ is still working fine, but I can't update it. Don't know what changes have been made in the firmware and as you say it's very odd that there is a new firmware release with no announcement or any info to be found on the website.
  • Took me a few attempts, but got mine to work on my Mac. I used the 'Stuck in Bootloader Mode' procedure from the FAQ and then it updated successfully.
  • edited May 2016
    Thank you, smfelton, for the tip. It worked for me too, but it took the iConfig to force quit twice: since the program hangs on the message "connecting" when I reconnect usb cable according to FAQ and (after successful upgrade) from USB1 (which is for iPad) to USB2 for work. By the way, it is not convenient: to use for flashing the only port that charges the iPad.
  • My ICA4 hung twice during the update process on my iMac. I forced quit the iconfig application, then I downloaded the latest version of iConfig. I opened the dmg file and copied the to my applications folder. I cycled the power on the ICA which still powered up in flash upgrade mode. I started the from my applications folder and selected upgrade firmware again. The ICA4's flash upgraded without a hitch. I think the glitch from the iConfig application has to do with the not being in the applications folder. It may be a permissions issue on the mac platform.

    27" iMac OS X Yosemite 10.10.5
  • so what does the new firmware bring?
  • Dave, there's a blog post about it. I'm on an iPhone and can't link easily, but you'll find it.

    Everyone else, I'll forward this thread tomorrow morning and see whether there's any good advice about this.
  • The update procedure simply doesn't work in iconfig (Windows 8.1). It's really ridiculous that no 1.10 file for a manual update is offered in the downloads section.
  • Nick - thanks hadn't seen the blog post. Still cant get update to work.

  • edited May 2016
    1.) We improved handling of large amounts of MIDI data across USB resulting in even better handling of large SYSEX messages.
    2.) We broadened support of Yamaha USB MIDI Keyboards - if you have a Yamaha keyboard that only connects via USB and one of our USB MIDI Hosting devices (iConnectMIDI4+ and iConnectAUDIO4+), your keyboard will likely be supported now if it wasn't before.
    3.) We made it so if you disable audio on our iConnectMIDI devices, then audio will no longer show up in USB descriptor.
    4.) We stabalized the preset saving routines. Some customers were getting corrupt saves, especially if they saved a lot - it should be better. Unfortunatly though if you have a current preset you like, we recommend you use iConfig to save the preset (best results if you save preset as MIDI file) and then recover the preset after firmware update.

    atm I don't have large sysex, no Yamaha keyboard, not the Midi version
    leaves the 'improved presets but still not bulletproof'
    not really worth the effort in my case

    cheers, Tom
  • Not having any luck with this upgrade under Windows 10. Have USB connected to port 1 but keeps stalling in bootloader mode on the "Download Complete. Rebooting to bootloader mode." dialog box. Rebooting does not seem to work. But at least the box is still running under 1.0.8 firmware.
  • Please try the following if you experience issues (and some people don't).

    Please read the following closely!

    1. THE LATEST FILE IS NOT POSTED YET (May 2, 1:00 PST), but it will be shortly. Instead of using iConfig to install the latest firmware, you can instead choose to download the MIDI SysEx files here:

    A. Then put the interface into bootloader mode, either from iConfig (under the Device menu) or by pushing the rotary knob: push and hold until each meter shows a single red LED, then release.

    B. Play the downloaded SysEx file from a DAW (set the tempo very slow) or another MIDI file player.

    2. Or you can try it this way:

    A. In Windows iConfig

    Ensure that there are no applications open on the computer such as browsers, DAWs, Skype, messengers, or any additional applications that may use audio or MIDI

    Connect Which device is best for me? to your PC

    Open your computer’s Control Panel/Device Manager/Sound, video and game controllers. The Which device is best for me? should be located here.

    Right-click the Which device is best for me? and select “uninstall”

    After successful uninstall, disconnect Which device is best for me? from the computer.

    Re-connect Which device is best for me? and let the computer re-install the device.

    After the Which device is best for me? is successfully installed, try opening iConfig and trying update.

    If issue persists try uploading firmware file using MIDI-OX

    B. With Mac, try this:
  • Please Be Advised... a VIRUS IS DETECTED when I try to download the updated Windows Driver:

    I'm using a Windows 7 PC with up-to-date Norton Internet Security active.
    The threat is name named: Trojan.Gen.SMH
    {ref }

    Note: This was also a temporary problem with a previous version of the driver.

    Maybe someone at iConnectivity could/should look into this...
  • It's safe.

    Our engineers did look into this. They ran it through Norton, saw the message you're talking about, and assure everyone there's no Trojan in there.

    We can speculate about what triggered the alert, but bottom line they think Norton saw something it doesn't know and is being overly cautious.

    Back to your regularly scheduled musical activities.
  • Thanks much for the feedback!
  • Just updated.

    Most difficult issue for me was figuring out I had the USB cable plugged into my router instead of my computer :^)

    I just grabbed the end that was plugged into a printer and plugged it into the ICA4

    Once I figured that out the firmware upgrade went very smoothly

    OSX 10.11.4
  • edited May 2016
    Well, still have the problem with midi implementation gone...
    Really, this upgrade with no clear information on forums, change log, on possible issues (midi implementation reported multiple times) and clear procedures to get back to normal, is just a nightmare for us...
  • Hello,

    ​Ok, I figured that to be in bootloader mode I had to use Iconfig interface.
    ​The procedure here :
    ​Explains that it needs to push the main button.
    ​For me, after red lights, it just reboots normaly, so I guess this procedure is not up to date.

    ​So what now ? Does the 1.0.9 is different from 1.1.0 ?
Sign In or Register to comment.