I just upgraded my iPhone 6 to IOS11, as a test for my iPad. The test failed. Before the test my iPhone played audio normally through the iConnectMIDI2+. Now what I get can best be described a a kind of stroboscope effect. Absolutely horrible.
When I plug in my iPad, still on IOS10, everything sounds normal. My Mac is on High Sierra. I restarted everything, but I could not fix it. 

I find this hard to believe. I googled for problems before upgrading, and I could not find anything like this. There have been about ten beta's of IOS11. How is this possible?


  • edited October 2017
    I updated my iPhone 6 S and iPad Pro to IOS 11 and everything works fine with my iConnectAudio4+. A better title for your thread should be: "Problem after updating to IOS 11 on my iConnectMidi2"... 
  • Yes, I agree that would be a better title, but that is not the biggest problem...
  • Just in case someone recognizes the problem I have attached an audio file. It plays from iTunes on my phone to Logic Pro, where I recorded it. Audio input was set to iConnectMIDI2+, no aggregate device was used.

    I also noticed that iConf did not really work on my phone, It saw my device occasionally, but then it lost the connection almost immediately without reading any info from the device.

  • Well, that audio file never finished uploading, so you will have to use your imagination. It sounds like music that cuts out every fraction of a second. I am trying to upload a screenshot of the Logic Pro track, but although this is only 5Kb it also does not seem to finish uploading.

    Meanwhile I have discovered that there is something called "inter device audio" that can send audio directly to the Mac via the standard charger cable. If I use that, the sound is completely normal. So apparently the sound is getting out of the lightning connector OK, but there is something wrong with the communication of the ICM2+ and the iPhone 6 with iOS11. 

  • Just tried iOS 11.0.2. The problem is not solved. I had to retry about ten times before the iPhone had a connection at all, and it sounds still exactly as described above. If I replace the iPhone 6 with my iPad Air 2 with iOS10, it works immediately.
  • Thanks Rodney! That completely solved this problem. I changed the clock source to USB port 1 clock, and did not change the buffers.
    Audio is smooth again. It was on internal clock, and with USB port 2 clock I had the same stuttering audio.

    Meanwhile there is still my second problem, connecting the device to my iMac. At the moment I have audio, but there is no way to predict when it will work or not. I submitted 3 tickets about that, but no response so far.

    But thanks for now, I feel better already. Would you recommend upgrading my iPad to iOS11?

Sign In or Register to comment.