Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Installation problems & "An unexpected error occured while trying to open a MIDI port."

edited November 2017 in Software
Device: IconnectAudio4+
OS: Windows 10 Home 64bit

I performed a reset of my Windows 10 PC this morning - fresh windows winstall removing all files/folders/apps etc.

Prior to doing this I upgraded the firmware on the ICA4+ to 2.0.

The first thing I did after Windows had finished updating was to connect my ICA4+ and try to install the driver and iConfig.


1) The manual says you need to install windows drivers, and points you to some images showing the process.  The images however relate to the installation of iConfig, not the windows drivers. 
This is a bit confusing, however I assume you install the windows drivers first (as an administrator) and then install iConfig, which is what I did.  

2) Iconfig would not launch after installation.  It advised of 2 missing DLLs.  Google told me they are part of Microsoft Visual Studio C++ redistributable 2010, so I downloaded that from the Microsoft website and repeated the installation.  It now seemed to work.
(what appeared to be happening here is that iConfig 4.2.6 was trying to install the 2013 version of MVSC and failing, but also needing the 2010 version of MVSC which was not included in the install).  

3) OUTSTANDING PROBLEM: Iconfig now runs but cannot connect to my ICA4+.  I am now getting the message "An unexpected error occured [sic] while trying to open a MIDI port. Please refresh to connect device again."  Refreshing just brings the same message up.
The ICA4+ appears to be installed OK.  I can get sound from it, and have now installed Ableton Live which can see all the channels and MIDI ports.
Without Iconfig however I can't configure the thing how I need it!

Hopefully points (1) and (2) will be useful feedback for Iconnectivity,  **** however what i REALLY need now is help with point (3).  Can anybody suggest a solution?  **** I have already tried previous version of iConfig to no avail.



  • edited November 2017
    Attempts to resolve so far:

    (i) Uninstall iconfig + driver, restart PC and reinstall both.
    (ii) Change USB port and repeat uninstallation/reinstallation.
    (iii) Uninstall / restart and reinstall with previous version of Iconfig.
    (iv) Uninstall / restart and resinstall with previous driver version.

    Currently getting same error message.  "An unexpected error occured while trying to open a MIDI port. Please refresh to connect device again."

  • I, too, reinstalled Windows 10 64 bit in my notebook, followed your procedures and I still get the same error message.   My ICA4+ has the latest firmware 2.0.    This is pretty frustrating.   
  • I submitted a support ticket.

  • Sounds like you don't have the correct Windows driver installed. Make sure you have this one:
  • edited November 2017
    That is the version I have installed.  I downloaded it from the website - there's no other options for the ICA4+

    I also tried the previous version (found on a "hidden" part of the website by googling) which made no difference.

  • I am wondering whether this has anything to do with Microsoft Visual Studio installation, as that was a problem when installing iConfig.


    Tried every single troubleshooting step I could think of, to no avail.  Contacted support who were not able to fix.

    Then, a Windows update was rolled out to my PC
    today  “Feature update to Windows 10, version 1709”


    This seems now to be working.


    So I guess it was a MIDI driver conflict
    with previous version of Windows 10.


    If you are experiencing this problem, I would suggest that you ensure your Win 10 is updated to this version.

  • In my case the update didn't work, but it the was Korg Microkey Air.   As long as I turn it on first, iConfig finds the ICAI4+ just fine.  

    I am glad that the unstable iConfig is phasing out.   Auracule seems to be solid.   It just needs to incorporate the audio/midi routing and advanced settings.  
  • HI Phil,

    You confirmed you already have the update, so maybe the windows thing was part of the problem/solution.  That is fixed now, and you have also identified that iConfig has flaky behaviour with other devices you are using.

    BTW If Auricle doesn't include the audio/midi routing what does it do?  That's the only thing I need iConfig for!!
  • Auracle currently includes extremely simplified routing. For some people this will be a huge improvement immediately, for some power users it might be less than they need. It will be expanded over time, but right now we're producing a "it just works" version :-)
Sign In or Register to comment.