new Windows MIDI drivers available

edited August 2017 in MIDI
We have just released our long-awaited multi-client MIDI drivers for Windows! These are recommended for:
  • mio
  • mio2
  • mio4
  • MIDI4+
They should also (partially) work on MIDI1, MIDI2+ and mio10, but those are not yet fully tested. Download from

These drivers are not recommended (and shouldn't be required) for users of our audio interfaces - they may conflict with the audio interface's driver that you already have installed.

If you own any of the devices listed above, please try the new driver and let us know how it's working for you.


  • Thanks, Rodney!  This is great news...very much looking forward to more robust drivers than the class-compliant ones! 

    So far, I can confirm that this isn't quite ready for prime time on the mio10 (or two of them) under Windows 10 x64 (10.0.15063 N/A Build 15063) as you stated above.  Each unit does show up as a correctly-registered and installed device in Device Manager using the iConnectivity driver, but each unit only exposes a single midi port pair (in and out) instead of the 16 pairs expected for each device.  I have verified this in the latest versions of MIDI-OX and Bitwig Studio 2 so far, but I can bring up other DAWs/software if you need more data.

    Please let me know if I can be of any assistance with respect to testing the mio10 with these new drivers; I have two units and I'd be happy to provide any further data or assist with any interactive testing if that would be useful.


  • edited August 2017
    So I have an iCA4+, a mio4, and a mio10.  I shouldn't install the drivers?
  • Not yet. We're hoping to have the full version for mio10 by next week if all goes well.
  • I see a new version of the mio4 driver was uploaded three days ago. Is there a changelog available?
  • Not at the moment. Main changes are support for mio10 etc. Probably worth downloading the new one anyway, there are a couple of tiny optimisations in there.
  • baxbax
    edited September 2017
    Thanks for the new drivers!  I have both of my mio10 units working together on the same Windows 10 PC and things are good!!!

    I have noticed an issue regarding iConfig 4.2.6 where I am unable to connect to either of my units after installing the 1.0.9 MIDI drivers. When trying to run iConfig I now get the following error:

    "An unexpected error occurred while trying to open a MIDI port. Please refresh to connect device again."

    I do not have any other software active or running that would be holding any MIDI ports. Clicking Refresh doesn't do anything, it is unable to detect either unit and the Device Selection window is empty.

    Any suggestions?  I'm trying to get into iConfig in order to adjust the USB MIDI port routing now that I have
    been able to attach a hub and am running some class-compliant devices
    (ReMOTE SL 37, Waldorf Blofeld). MIDI communication with these USB devices (on Ports 11-16) works fine, but I want to adjust the routing of the MIDI from the USB ports to go to specific port(s) rather than all ports (which it is currently set to).

  • Like bax above, I cannot edit my routing in the iConfig software as the opening screen doesnt show any devices. Refresh does nothing and reboot obviously didn't help either. I only recently purchased MIO4 and had the software working once but haven't been able to make it work since. Any suggestions whats going on?
  • I have managed to get my MIO4 to work with iConfig but it required a workaround (and perhaps luck?):

    I managed to have the MIO4 detected in the Device Selection screen by rebooting my pc and pressing 'F8' early on before windows boots up, then scrolling down to "Disable Driver Signature Enforcement”. This is a temporary disable so it shouldn't affect any users, but it did allow the drivers to load and detect my iConfig. I have made all my changes and made sure to 'save current settings' (under Device heading) as saving the preset wasn't enough the first time! should have combed through the manual better!

    I hope that helps someone else!
  • That's very weird. We will investigate!
  • Thanks Rodney. I can confirm that after a few weeks fiddling with the MIO4 I can never access the iConfig software as it never detects a device, but can always access it when I've Disable Driver Signature Enforcement. I'm on Windows 7 btw.
  • Windows 10 Defender Virus and Threat real time detects on download that has the virus 


  • Wow... that's not good. Will investigate. Thanks for letting us know!
  • That's weird, I just downloaded it and tested it on my Windows 10 box and both F-Secure and Windows Defender give it a clean bill of health.

    Now I'm very confused.
  • Hello, I'm new here with my MIO10, it works without installing any driver on Windows 10 64b, maybe it's installed by itself on 1st use, I've tried to install the driver from the link but it install an Asio driver too, that is useless for a mio 10 no ? 

  • The latest Unified driver contains an ASIO driver and a MIDI driver combined. Just install it and ignore the ASIO part. The interface will run without it, but you may have trouble trying to run multiple applications at the same time.
  • OK, so I'll have Asio of Iconnectivity always open ? it's confusing, hope it doesn't creates problems with Asio4all or my Focusrite's Asio. I'll try (in fact I haven't planned to use the interface with multiple programs at the same time, because I know Windows don't like it, but if your driver could do this it's interesting)

  • you dont need to open the iconnectivity control panel or use the ASIO driver. Just install it and forget it. it will work in the background.
  • I have a bug report related to drivers. After installed it's (still) working, and Auracle sees the interface, but on Reaper the Midi options are a mess now. Before drivers, I've in Reaper Midi option the Mio midi in order (Mio 10 din Host 1.2.3...) and I've renamed with my synths names. After driver install names are gone (ok I could write it again) but no more logical order and no Mio name (like : Din3, Hst 2, Din7, Din1, Hst 30...) and different order on IN and OUT windows. I've uninstalled driver and it came back in good order and names too.
    Windows 10 64b
  • I installed this driver for my mio10 and now Cubase 9 often hangs when I start it.  I have to power cycle the mio to get Cubase to open.  I think it's related to putting the computer in sleep mode.  It seems that the mio doesn't wake up properly.
  • Did it work properly with an earlier driver?
  • edited February 2019
    Yeah, I never had this problem.  It hangs right here:

    If I kill Cubase and power cycle the mio, then it will start normally.
  • I suggest putting in a support ticket with as much relevant info as possible so we can try to track down what's happening. Also make sure you have the latest firmware installed for the mio.
  • I installed the driver as instructed. tried using it in Ableton live 9 and Reason 10 and in both instances it did not work

  • That's very odd. Was it working ok with a previous driver?
Sign In or Register to comment.