Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

iPad not recognizing iConnect Audio4+

My iPad pro does not recognize that I have plugged in the iConnect Audio4+.  The lighting cable is connected to the iPad and the iConnect (I am getting power from the iConnect), but all of the sound comes out of the iPad internal speakers.  When I open AUM or Audiobus, the only hardware input available is the internal iPad microphone.  The iPad also does not recognize any MIDI signals from the iConnect.

It was working earlier this morning, but seems to have gone away for no discernible reason.  I have tried resetting iConfig software to factory defaults, rebooting iPad, plugging and unplugging lightening connection.

I am running the last firmware on the iConnect and use Windows 10.  I am able to use all of the hardware synths I have connected.

Do I have a bad lightening cable or USB Jack?  Has anyone else experienced (and hopefully fixed) this problem?


  • I have the same issue with a 2+.
    I had the unit connected to a Laptop and it worked just fine THE VERY FIRST TIME I USED IT since is new, i just received it...then when i come back to actually use it with the band to play some sequences(the day after), the thing doesn't work, is not recognizing the Ipad.   I connected an iPhone and it works but i couldn't select the outputs.   After all the show, i connected the unit to a Mac and then detected my iPad BUT the first time gave me Out 1&2 and Out 3&4 and now i can't select stereo outputs to work on 3&4, instead gives me just Mono out and gives me 8 channels so i don't know what happened.
    Try to connect another device and if you think is your cable, well,,,try another cable.

    In my case, i think i;m looking for help on configuration but that is my story...maybe you need more power just like my iPad.

    (let me know also if you know any solution on my case)

  • Bad experience as a brand new owner here as well. I use an iPad 9.7 2018 plus a Windows 10 PC. It worked fine at the very first attempt, but now (second attempt) the iPad just  won't recognize any connection to the iConnect 2+ and won't even load power over the connection. I rebooted the Pad to no success and even reset it. No dice.
    I opened a ticket right away, but if this thing is really that finnicky, it's going back - with a tear in my eye, because while it worked, it was fantastic. Now it's merely a doorstop. An interface for my PC I already own, I just bought in because of the iPad integration.
  • Phew! Today I had the opportunity to try a different cable between iPad and iConnect. It worked right away and so far I didn't run into this issue again. iConfig on my Windows PC did report a connection error twice (within about 4 hours of messing around), but recovered soon after both times. Re-connecting the iPad after breaks works a charm right now.

    Seems like a happy end on my part at least and solved with a cable switcharoo, sorry for panicking. I hope the connection errors I encountered are due to me tossing around buffer settings too much.

  • Gofer, iConnectivity original cable?!
Sign In or Register to comment.