Problem with firmware 1.0.7 update

I am trying to update firmware to 1.0.7, but am still seeing the Firmware Upgrader message "Download complete. Rebooting to bootloader mode." message with the scrolling progress bar after 5 minutes.

I connected my W7 pc to the port 1 connector and have the yellow flashing lights on the device, but it sure looks stuck to me! All I did was connect the device to my pc, power up, and launch the iConfig program, and accept the message to update the firmware.

How long should this take?


  • Ok, so after 30 minutes I got tired of watching the progress bar scroll across the page so I closed it with the "X" in the upper right corner. Now I am looking at the iConfig window which has the tabs across the top displayed but is totally blank when I click the Device Info or Audio Mixer or any of the other tabs, and now has a small scrolling indicator on the bottom right of the iConfig window in permanent scroll mode.
  • Ok, I tried to reboot the device, and now I am seeing an error message everytime I try to launch the iConfig program saying "An unexpected error occured (sic) while trying to open a MIDI port. Please restart the application.".
  • edited June 2015
    @agfrag: exactly the same problem, still have no solution. Check my other threads.
  • Sorry for the troubles. Have you guys tried updating manually using the instructions here:

    Let me know if you still have problems after trying the above.

  • Yes, yesterday I finally managed to update to firmware 1.07 'manually'! After having the same problems with iConfig as mentioned above. I downloaded the firmware midi-file from and I downloaded and installed MIDI-OX (for Windows) (see link in the 'Whitepaper'). I followed the instructions from the 'Whitepaper', except that I used iConfig (still usable for me, after a reset) to put the iCA4+ in bootloader mode (via Device -> Reset to Bootloader Mode). I played the firmware-midifile and could see the iCA4+ reacting with flashing lights. Then the 'Whitepaper' failed on me, because pressing the rotary knob on the device 'for 7 a 8 seconds' didn't work and nothing happened, except that the iConfig screen went white and I had to 'kill' it with Windows Taskmanager (grr...). BUT: after disconnecting iCA4+ from its powercable and connecting it again, everything seemed normal and when I restarted iConfig it showed firmware 1.07 and everything worked! Still, I'm not too happy, because now I notice more digital cracklings and also experenced for the first time the 'digital noise' on top of played audio that's mentioned before in another topic... Have to experiment more with buffer-settings, I guess, etc.
  • Hey @Haropus - would you ming documenting the trouble you are having with iConfig here:
    That way we have all of you details documented so an in-house tech can try to create the issue.
    Typically if we can recreate it, we can find the solution.

    Appreciate your patience in the meantime Haropus.
    Sorry for all the trouble.

  • Well, don't know why, but just for grins, and without making any changes, I tried again yesterday, and it worked. This is some buggy stuff man. I now have a new (3rd) issue, I'll open up another thread.
  • edited June 2015
    I just received my MIDI4+ today and began to update to firmware 1.0.7 per the prompt in iConnectivity. The update was successfully downloaded, but the upload to device ran 30 minutes with no progress made in the status bar.

    I force quit iConnectivity then attempted the update again with no problems.

    No harm in trying out that fix on the AUDIO4+.
  • edited June 2015
    Sometimes an update may take a few attempts before the hardware will take the update. This will happen outside of iConfig as well, while running a manual update with a third party SysEx utility. It typically has to do with the USB buffering. If there's a little hiccup in buffering the data, the update will fail.

    Thanks for creating a ticket @agfrag
    The more we have documented, the better our software and firmware updates will be.

    Thanks for your help,
  • edited June 2015
    It would help then if iConfig could trace such a 'little hiccup'-failure and react with a message-dialog and just close the update-procedure, instead of endless waiting (for alt+ctrl+del (in Windows) as a drastic but only way out). Just an idea...
  • I can put together a feature request concerning this @Haropus and see what the dev team can do. Appreciate the feedback.
Sign In or Register to comment.