Failed firmware upgrade to 1.0.8 - device unresponsive

Hello there. I've already opened a support ticket, but you seem to be more responsive in this forum. Here's what happened:

iConfig offered to upgrade the firmware, so I clicked yes and it rebooted the device. After that, two red LEDs showed up at the top while two orange lights kept blinking side to side. After a while iConfig closed by itself, leaving the device stuck in this state. The device now powers up and keeps showing the two orange lights blinking.

No MIDI or Audio ports show up on OS X (10.10.4) anymore. iConfig can't see the device (obviously). I tried initiating the manual firmware update procedure, but the situation stays the same. Is the device bricked?

It's still on warranty (I bought it last month). If there's any other ways to load a firmware, please let me know. I have the MIDI file for 1.0.7 and plenty of 5-pin midi devices I can attach to the unit. Although it's still covered in the warranty, I'm not afraid to open up devices if there's an easy(-ish) solution that could avoid me sending back the unit to you for repairs.


  • The support ticket is #329527 by the way.
  • Come on, iConnectivity, your hardware seems and proves to be very good, but your software (iConfig) is not reliable and needs to be improved!!! I also had problems with an 'automatic' firmware update (from 1.06 (?) to 1.07) and did that manually and that went well, and now I don't dare to automatically update to 1.08 via iConfig, but can't update manually because there's no download link for that firmware file! And qua software I also worry if there will ever be an iPad-iConfig-app...
  • edited July 2015
    Hey @fzero - thanks for opening a support ticket, they will take good care of you. You cannot "brick" the hardware using this process. The update will either complete successfully, or it will not (make sure to be using device jack 1 anytime you update). Although, it may leave your hardware without FW. In that case, you will need to update in [bootloader mode] - hold the master encoder for a few seconds after powering it on. then when you see the yellow lights toggle back-and-forth launch iConfig and choose the hardware listed with [Bootloader mode]. Also to avoid any issues, make sure you are using the latest version of iConfig from the website.

    Hey @Haropus, could you explain in detail the issue you're having when trying to update to better assist? Are you having trouble getting into update mode? Is the download not pulling or is the hardware not respond? Do the yellow lights toggle, do you see any activity on the LEDs? Let me know - as much detail as possible is appreciated.
  • Thanks @jsandeen. Support just contacted me and I managed to get it to work. I had to reinstall iConfig first though; apparently something happened while it was updating (or before, anyway it seems it was a bit broken).
  • edited July 2015
    Great news @fzero - appreciate the update.
    Let us know if there's anything else we can do for you, or feel free to start a new thread in the future.
  • Hey all - our iConfig current versions for Mac and Windows were built using a MIDI Library that unfortunately does not give us sufficient view into the driver status - we therefore rely on timeouts and polling to determine when device has rebooted into our boot loader mode. Unfortunately this is not working solidly, especially on Windows machines. Latest version of iConfig (4.1.2), now available tries to make this better.

    We are working to redesign iConfig to better resolve these issues.
  • Hello @MikeL, so there is hope for the future (:)); thank you for letting us know this.
  • We appreciate all the feedback Haropus (and everyone)!

    Let us know what you think of the new version of iConfig.
  • I have the most up-to-date version of iConfig (4.1.2) and am having the exact same issue as the original post. Do I need to open a support ticket or is this a well known issue at this time with a simple fix? The device is connected to my Mac on port 1 .. iConfig sees it and asked if I wanted to upgrade the firmware .. I said yes .. and now it has been stalled on "Reboot complete. Loading firmware" for over 30 minutes without any movement of the progress bar. Any suggestions for what to do? Should I unplug it or will that create bigger problems? Thanks for any help.
  • I actually did unplug it and then re-installed iConfig .. then retried the FW update and it worked.
  • I have this problem, too.

    The advice above to reinstall iConfig (v4.1.2) didn't work.

    Device got stuck in bootloader mode and message on the PC was "devive not responsive"
    here are some infos to help trace down the problem:
    - Current device firmware version 1.0.5
    - Win 8.1

    Can you help me please?
    Actually I tried this to (maybe) solve the problem of digital noise, which I get after using the iCA4+ after some 10 minutes. There was a thread about this, which I don't find anymore...
    And the noise problem is (of course) annoying as hell. Btw, It happens always.
  • Please file a support ticket, vogli. This is that kind of issue.
Sign In or Register to comment.