iCongfig and device driver

edited July 2015 in Audio
I've had all kinds of problems getting this to work. First, the iConfi
Now, iConfig won't run because my computer keeps g software wouldn't start because MSVCP100.dll was missing. I figured that out - it's part of Microsoft C++.
Now it won't run because my computer keeps trying to find a driver for it. If I reload the driver, it'll start, tell me there's a firmware update, and when I click on that the computer starts looking for a driver again and I get a message that there are communication problems (can't remember the exact words) and the software doesn't show my Audio4+.

Any help? I haven't heard back on my original support ticket.

**Edit**
I got the firmware updated, but it still goes through the "looking for a device driver routine every time". I have to be away from the rig for awhile and I don't know whether to unplug from the computer, unplug the power, or leave it connected (which I'm doing). There is no 'disconnect safely,' from the computer and no power switch....what do others do?

Thanks, I have spinal stenosis and can't sit at the computer for long stretches - I'm in some pain right now, so forgive me for not introducing myself properly. I'm very sorry if I seem abrupt.

Comments

  • You can switch the iCA4+ off as follows (from the manual): "Push and hold the rotary knob until each meter shows a single red and a single amber LED, then release." (To turn it on again, just push the rotary knob once.) That's the way I do it.
  • Thanks, Haropus! I need to get farther into the manual - I didn't see that
  • @PeterDoubt - there is no need to worry about "disconnect safely" with iConnectAUDIO4+ - you can disconnect and connect any time.

    In the past week we have noticed that on some Windows 7 machines, it is taking time to start up iConfig ourselves. Are you running Windows 7?

    We are continuing to look into it. Personally I wonder if a Windows 7 update is causing issues and the machines we experiencing slow startup on have been updated more recently than those that do not.
  • edited July 2015
    @MikeL - I am using a laptop with Windows 7 Premium 64bit. It had been upgraded to Windows 8 but had all kinds of problems so I installed a new 7200 rpm 1tb hard drive and restored it. It seems like it's updating every time I restart. I'm confused now about why it keeps looking for a driver when I connect the Audio 4+. Last night I had to reinstall the driver from the IConnect site again to get it recognized. I'm sure you guys'll figure it out. Now I'll have to see if it will do basic recording and then look into all the other features!
    Is it possible to hook up something like my Presonus Audiobox 1818 and get more tracks?
    Thanks, I'm excited to get this going with my iPad and PC DAW,!
  • edited July 2015
    Hey PeterDoubt - you can add inputs or outputs from additonal hardware in your session by using ASIO4ALL (free download on their site). This allows you to pair multiple hardware (WDM and/or ASIO) in order to use them at the same time in your recording software. Then you choose ASIO4ALL as your sound device within your software's preferences.
    (If you just wanted to use the MIDI from both interfaces, you would not need to pair the hardware like this)

    Let us know if you have any other concerns,
    -JS
  • @PeterDoubt, further to jsandeen response - ASIO, although a great workaround for solving Windows MFC latency issues, was not designed to have more than one ASIO instance active at any one time - unfortunate design oversight. Most of us do not release ASIO classes that work with more than one piece of hardware cause we all work to optimize for best performance. As suggested by jsandeen, ASIO4All is the only solution I know of to have aggregation of multiple hardware in ASIO object. As with any system though, to aggregate you need large buffers and sample rate conversion - which adds latency and signal degradation.

    Again, unfortunately the only solution currently to aggregate multiple hardware interfaces for audio.
  • Thanks, both of you. Would the Presonus be plugged into another USB on the computer, or into the ic4+. ? I've used ASIO4All, but I've never combined devices. The latency and degradation sound like you have to weigh the benefits,with the cost.
  • edited August 2015
    The other audio interface would be connected to another USB port on your computer. Then the your computer and ASIO4ALL would handle the pairing. On Mac, OSX has an 'Aggregate Device' section that lets you do the same thing.

    Yes - correct, the additional latency is something you want to take into consideration. Typically when you combine two hardware and drivers like that, many people will report additonal latency than compared to the interface is running without ASIO4ALL or Aggregate Device. But It's not a show stopper and there are ways to control it using your software - but of course you can't completely eliminate it.

    Let us know if you have any other concerns about your set up. Glad to help.

    Cheers!
Sign In or Register to comment.