Help! New AUDIO4c owner setup woes. Troubles with Auracle and IConfig

HI! I'm so excited to finally get one of these! However I am having a difficult time setting up. My iMac is running Big Sur 11.2.3 and I think I have the latest AUDIO4c firmware (no yellow exclamation in Auracle).  The AUDIO4c is hooked up only to my iMac (via device port 1). I also have a powered usb hub plugged in via usb host jack with a plethora of controllers and synths hooked up. I was hoping to reserve midi ports (and rename) via iConfig on iMac _before_ hooking my iPad to device port 2.  HOWEVER, I have a tough time maintaining/forming connections with Auracle (for X-series) and iConfig. I seem to be able to connect using either software _once_, and then both programs have problems (freeze, crash or drop connection) and then neither program will recognize the AUDIO4c until I turn it off and back on again. For example, I just turned power off and back on via long presses of the knob on AUDIO4c and then was able to then "see" the unit in Auracle. I then tried to reserve midi hosts... first two worked fine, but then it would not let me reserve any others... and then Auracle suddenly dropped connection and no longer shows the AUDIO4c . If I launch iConfig at this point the AUDIO4c (represented by my serial #) does not appear. SO.... now if I power off and on, iConfig (and Auracle) finds my device. If (in iConfig) I now try and reserve and rename some midi slots.... I can assign and rename two (just like in Auracle) but on the third resere iConfig gets angry and displays a pop-up "There was a communication error. Please check device connection". If I press "OK" on that error pop-up iConfig immediately looses site of my device (as does Auracle).... until next power on/off. HELP!!!!! What is going on? I wish both programs *always* could connect... isn't that the normal behavior of the software?

Thanks for any help... already lost a day to this.... :(


  • edited November 2021
    Actually... while all that "worked" above as I typed it,  subsequent power cyclings have not let me see the device in either program. So frustrated
     :( :( :(

    But even when Auracle and iConfig don't see/list the AUDIO4c, Apple's "Audio Midi Setup" utility does.... weird!!!

  • I should say this is MOSTLY fixed now. I can connect to Auracle and iConfig whenever I want (just not "however" I want). Partly the problem was my inconsistent powering down technique via front knob... which I have fixed now thanks to reading the AUDIO4+ manual section "Rotary Knob Push functions" (iConnectivity... please include this VERY helpful section in the AUDIO4c manual! thanks!). The other problem was that a couple of my devices were multi-port (Nextar Impact L25+ and Korg Minilogue XD) and these would cause iConfig to lose connection when I set iConfig's "Maximum number of ports to use on multi-port USB devices" to 2. I don't know why.... I would love to get them to work... at least the nektar because when I only use it's first multi-port the knob motions are not transmitted. :( If anyone knows how to solve that problem I would greatly appreciate the help! Thank you! 
  • I would definitely recommend using Auracle X for your setup needs.
    What are you seeing in the USB host reservation page when you click on the dropdown menus in Auracle X?
    The multiple ports have different functions, which you may need to consult the manufacturer of that gear about, to get details.
    Often port 1 is the only one needed but I know some devices use port 2 or 3 for DAW integration and Mackie type work.

    I appreciate the feedback on the knob. I thought we had a section in the AUDIO4c manual but I will take a look at that today.
Sign In or Register to comment.