Mio 10 Drivers?

Hello,
I am having trouble finding the right drivers for my mio10. I've tried both available unified drivers, 4.82 as well as 5, but neither midiox nor iConfig recognize the midi interface. Anything I might have missed?
The device manager does show a mio10 d2 device, but it is not clearly identified as a midi interface either.
Thanks

Comments

  • All okay, I've tried to access the machine via rdp. This somehow does not work, vnc is fine. This way the mio10 does indeed work without any additional driver, as stated in the manual.
  • Feel free to contact support with your issue so you can do some troubleshooting.
    What driver is being accessed by the mio10 in Device Manager?
    - The unified driver (5.0) should be the correct one.
    Can you check which driver the interface is accessing?
    • Go to Device Manager
    • Under Video, Audio Controllers
    • Right Click the interface name
    • Go to Properties
    • Go to the Driver tab on new window called "drivers"
    • Which driver is set on top as the primary driver? Microsoft or iConnectivity?
    ​​​​​​​
  • I stopped being able to see my Mio10, I randomly plugged the USB cable into the front and could see it right away.
    I have no idea why.
  • @tsho08: Thanks for getting back to me and sorry, that I have not been clear: The issue is resolved, it is a Windows thingy. Somehow, when connectig via RDP, the interface does not get recognized. When using VNC instead (and almost certainly locally, too), everything works fine. At least iConfig now recognizes the device, I have not had time yet to extensively test everything.
    So Windows seems to limit USB port usage for some devices when being connected to remotely. At least using it's native RDP protocol with standard settings.
  • Let me know if you run into trouble. Please release any information that helps you solve a problem on here. That's the best part of forums. Seeing how other people got tot he solution of their issues.
Sign In or Register to comment.