MioXL issue with MacOS 13 and Midi-RTP (duplicate participants and overload)

I've been trying to use RTP instead of USB but I run into a weird issue I don't even know how to begin to debug. I enabling a port as initiator in AuracleX 1.9.1. Then in MacOS 13 I enable the the session in Audio Midi Setup.
Shortly afterwards, the list of participants will start filling up first with one entry as expected (showing the correct name as configured in AuracleX). But then more and more entries of the same name will appear in the list of participants. When I leave this running for a while, I cannot connect to the mioXL via Auracle anymore, or if I can, the connection is incredibly slow and gets dropped frequently. After disabling the session on my Mac (and restarting the mioXL Auracle works fine again.
I've followed every video and support article I could find, searched forums but I couldn't find anyone with that duplicate/dozens of cloned entries issue. Any clues on what goes wrong here?


  • Try turning off wifi, have the same problem
    Hope it helps
  • Thanks, I've tried that and it actually worked for a while. Until some day the issue reappeared. 
  • This could be a few things. Apple has had a load of network type issues on Ventura. I'm typing from a computer on a different OS on wifi because my computer on Ventura (13.2) connected over ethernet is having network issues.

    One thing that helped me for the RTPMIDI gear staying good is using static IPs on my network and my interfaces.
    If you get cloned participants in a network session it means the connection is happening and then breaking. Since the RTP is in Initiator mode it tries to auto reconnect before Apple has done it's refresh and kicked the previous not working participants. 
    Then you might get a big list of failed connections. To get the only active RTP port in participants you can make the network session not active to wipe them all and reactive and the one will come back.

    I still think Apple has some bugs here that they haven't spoken about and I hope they fix. I've been working to narrow this down but it's definitely the Mac OS version for my machine causing disconnects. I was good until 13.2 and my system suddenly gets no internet and even caps out my speeds at under 100mbps. 
    I connect the same ethernet cable into my old (2012) Mac mini and I'm running closer to the normal 900+mbps it should. 
Sign In or Register to comment.