Devices tested with USB Host Port connection

edited June 2017 in MIDI
One of the coolest things about our interfaces is the USB Host Port which enables you to connect USB MIDI devices without having to go through your computer. Unfortunately there are a few devices that do not work because they expect some special commands directly from a computer that we can't provide. We've been assembling a list of those that we've tested, but we obviously can't get our hands on every piece of gear out there. So if you have something you have tested with our Host Port, let us know and we'll add it to the list.


  • Korg Nano Series (Kontrol, Key, Pad)
  • Looptimus & Looptimus Mini Pedals
  • M-Audio Axiom Series
  • M-Audio Axiom Pro Series
  • M-Audio Axiom AIR Series
  • M-Audio Keystation Series
  • M-Audio Code Series
  • MIDIPlus S6
  • Novation Sl Series
  • Nord Stage 2 EX
  • Roli Seaboard
  • Yamaha CS1x

Partially Working

  • Arturia MiniLab
  • Arturia SparkLE
  • Novation Launchpad

Not Working

  • Ableton Push
  • Livid Base DS-1
  • NI Kontrol Series
  • NI Maschine
  • NI Traktor S2


  • Hi Rodney,
    One question before the community provides info about devices:
    Does it make sense to try to collect more specific test results, what has been tested?

    For example:
    *send notes: | yes | no | not tested |
    *receive notes
    *send clock
    *receive clock
    *send CC
    *receive CC

    Of course there are a lot of devices that can't be tested for some of those "categories".
    Or do you think that would be an overhead and a simple | yes | no | partially | is enough information?

    Best regards,
    Bob Lee Swagger
  • edited June 2017
    Working and Not Working are pretty much as it says on the tin, the only grey area is in Partially Working. I thought of maybe explaining the stuff in there more closely but I wasn't sure how useful that would be to people. 

    From our internal testing Partially Working means that all the basic MIDI stuff works, but some more arcane features that depend on the device querying the computer directly might not get recognised. For example the Arturia Minilab works perfectly except that the Arturia AnalogLab software doesn't automatically recognise which specific model you have connected and you have to choose it manually. That means it's effectively 99% working but I still thought it better to err on the side of caution when making the list. So maybe we should change that heading to Mostly Working :-)

    But any more specific feedback the community can give is always welcome of course!

  • The devices I have hooked through a USB hub to my mio 10 (and work, at least as far as sending/receiving MIDI goes) are:

    Roland JD-XA (MIDI only, not audio)
    Sequential Prophet 6
    Casio PX5s
    Arturia Beatstep
    Arturia Keystep
    Waldorf Rocket
    Waldorf Streichfett
    M-Audio Venom
    Korg KP3
    Korg Kaossilator Pro
    Ashton Rhythm VX (aka Legacy DD501) drum kit 

  • Thanks Timespy, will add to the list, which I'm hoping to post as a FAQ later today.
  • Updated list now on our website. Thanks to timespy and everyone who has contributed so far - keep your reports coming in please folks!

  • this list contains devices that can receive a midi clock of my ICM4+ USB host port.
    recieving clock is the only functionality i have tested!

    Alesis iO Dock II (with iPad Pro)
    Roland JD-Xi
    Korg KP3
    Korg KP3+
    Arturia Keystep
    Future Artist MIDI Looper

    Not Working:
    Roland System-1
    Roland TB-3

  • Thanks for that Bob. I haven't added your working ones to the list yet because I'd like to check that they are working with more than just MIDI Clock. Pity about the Roland devices not working :-(
  • I really would like to provide more test results but i was not able to get anything working.
    My preparation in iConfig was to enable all(!!!) midi port routings and disable all filters. So i expect that any key-down event will be sent to all ICM4+ OUT ports (DIN + USB)

    My testing setup A was:
    "KORG nanoKEY2" on one port of the USB hub. (this device is listed as working in your list)
    "Roland JD-Xi" on another port of the USB hub.
    Key-down events on the nanoKEY does not trigger notes on the JD-Xi

    My testing setup B was:
    "KORG nanoKEY2" on one port of the USB hub.
    "Roland JD-Xi MIDI IN (DIN)" to ICM4+ MIDI OUT2 (DIN)
    Key-down events on the nanoKEY does not trigger notes on the JD-Xi

    My testing setup C was:
    same as setup A but i replaced the nanoKey with "Arturia KeyStep" (this device is listed as working in timespy's list)
    Key-down events on the keyStep does not trigger notes on the JD-Xi

    My testing setup D was:
    same as setup B but i replaced the nanoKey with "Arturia KeyStep"
    Key-down events on the keyStep does not trigger notes on the JD-Xi

    Obviously i am doing something wrong here. Can you point me in the right direction?
    (i double checked midi channel settings so this shouldn't be the problem)

  • Hi bobleeswagger, have you tried with something plugged directly into the USB port without the hub, checking communication with a DIN port? The problem could be the hub or the cable between the iCM and the hub
  • edited June 2017
    Hi timespy,
    now i tried without the hub and had the same result.

    But i found out that my iConfig did not behave as i expected:
    hitting Ctrl+A within the tree of the "filter section" selects all. i thought my filter setting changes will apply to all inputs/outputs. but obviously iConfig has some different behaviour...

    Anyway - After renaming my connected USB devices and carefully double checking routing+filter settings everything works!

    Roland JD-Xi: sending and receiving midi notes via ICM4+ USB host port works!
    Teenage Engineering OP-1: sending and receiving midi notes and receiving clock via ICM4+ USB host port works!
    Future Artist MIDI Looper: receiving clock and powering the device is the only reason for its USB port - so there is nothing else that can be tested and it should be listed as working

    *EDIT: also sending and receiving midi notes on the Future Artist MIDI Looper (without using DIN ports) works perfectly
  • Glad you got it all working, and thanks so much for the test results - I will add them to the official list now.
  • edited June 2017
    A mate joined with a
    Novation Mininova and we gave it a try.
    It's not listed in iConfig after plugging into the host port and it does not respond to usb fired midi events.
    So it can be listed as not working

  • edited July 2017
    Hi bought a MIO4 and been going through my gear and seeing what I can pull out of the old DIN network.

    Tried out my old Novation Remote 25, but I think it might need more than buss power as it dimmed up when I connected it.  I haven't found a psu for it laying around, so that is still untested really, but I have high hopes of it working once I do get it some wall wart power.
    The Circuit was another that acted strangely though it could have been due to a poor quality hub not coping with the number of devices on it, so again I need to revisit it now I have a better hub and have my head around what info it actually responds to.  It's a funny little box as far as MIDI goes.

    I'm running a myriad of sequencers and synths and am testing from a powered 6 port hub generally with a Pyramid, Keystep or Beatstep Pro as the source.  I have an old MIDI analysis box I'm using to check what messages are making it.  I've routed the CC data from USB attached devices to a QY700 and am catching it all there.  All seems to be the way it should with working devices.

    Novation Remote25, ZeroMKII, Circuit
    Waldorf Pulse 2, Blofeld, Streichfett
    DSI Tetra
    Wave Ideas Bitstream 3x
    Squarp Pyramid
    Arturia Beatstep Pro

    Novation Zero SL MKII (just making sure mine wasn't a dude)
    Waldorf Pulse2
    DSI Tetra
    Wave Ideas Bitstream 3x
    Squarp Pyramid

    Yet to be tested
    Behringer BCR-2000
    Arturia Minibrute
    Novation XStation

    Retesting either directly connected or with ext. power
    Beatstep Pro
    Remote 25

    I'm not going to be using either of the Arturia sequencers directly connected to the MIO4 as I'd rather them to be freely routed via my patchbays.  They both end up in the MIO4 via the controllers regardless, so I'm not going to bother double checking my Keystep works, but I will exhaust all avenues with the Beatstep Pro, just need to find my Y cable for it first....

    I'm surprised the Blofeld is not being seen as both my other Waldorf synths with USB are working, no worries.  I'm going try again directly to the MIO4 and also a different power-up sequence for the devices.

    Very pleased with my MIO4, which I initially had earmarked for running as a MIDI filter to reign in some problematic reset messages the QY700 likes to send at the beginning of sequences and never intended to use the USB host.  Now I have it running middle-man for coordinating two MIDI patchbays and an automated mixing desk.
  • Okay, tried the Remote25 under power to the MIO4 via a hub and directly with no joy.  Then I remembered that it was an absolute nightmare to make work with a computer years ago when I first got it.  My crappy Edirol was a plug'n'play fairytale but this was determined to not play ball.  Works well as a simple splitter/router, too bad that did extend into the USB world.

    Next the Minibrute with was seen no worries but wouldn't respond to anything sent to it but was sending notes and mod/bend wheel data.  I did my best to find out what the Minibrute responds to via USB and found a post on their forum stating it could be sent MIDI via USB though nothing I did effected the synth.  I didn't check the 'hidden' parameters only controllable via MIDI, but am fairly sure it'll get them, just Arturia really did have an ethic of "this is an analogue synth" to the point of if they could have got away with putting no MIDI on it at all and run the thing entirely on CV, they would have.

    Now the Blofeld.  What a shame.  Like the Remote25, it just didn't like the MIO4 at all.  Not from behind a hub, not connected directly, not when powered while connected, not connected after power-up, not connected prior to the MIO4 being powered up, not in any way, shape or form.  Bugger.  The other two were so easy and put a huge smile on my face when I saw them there.  Oh well, not that it would have provided me with any extra functionality, as I more use the Zero to access it's parameters.

    And the last one I did last night was the Beatstep Pro.  This one was a worry before I hooked it up due to all the issues users have posted on their forum about getting it to play nice with DAW's.  It's also loves to bring the noise if it's 'power' cable is too near others or running straight into a computer.
    I found their solution to the noise, the USB Y power adaptor and tried it out.  Remembering something I read about getting it to work on a computer, I plugged the power to it first then plugged the 'computer' end into the hub.  Low and behold, two ports show up in iConfig.  Woohoo!  All well and good, but are the doing anything?  I only tested port 1 and only for receiving data from the BSP.  Not a problem, everything worked as if it was running from the DIN ports.  I have to mention though, the BSP is on firmware v2.0.0.x and it wasn't when I first tried it with the MIO4.  Dunno if that made any difference as I only tested the BSP from behind a hub and figured if it's working from there, all should be good connected directly.

    So, the tl;dr version:


    Beatstep Pro

    Not Working



    I'll get to the last few machines tonight.
  • edited July 2017
    Weird, I can't find the options/edit button for my posts so have to triple post, please excuse my for decorum!

    I retried the Minibrute as I thought it weird that it would be sending data yet not receiving and I got it to sound, so that is fully working and not just a MIDI implementation.  Oddly though it has two ports showing up but only one sends and receives....

    Worked how edit works.

    XStation is working, on bus power from a powered hub.
    Seems the XStation is like my old '88 corolla, I just left it for a while and now the screen works.
  • Thanks very much for this valuable input. 

    Oddly enough I just got a Blofeld keyboard last week (birthday present for myself) and it's working perfectly plugged into a hub into the Host Port of my iConnectAUDIO4+, so it should work on your system. I'm running firmware 1.23 with all other parameters set to default. Not sure why you are having problems there... That's a wonderful synth, I'm very happy with it :-)
  • Have now updated the FAQ to reflect your findings. That's really helpful, thanks so much!
  • edited July 2017
    You are very welcome.  I think that iConnectivity have a great range of products and I love that I get to put a white lab coat on for a little bit while getting my MIO4 integrated.

    With the Blofeld, I had some problems with mine when I updated from 1.03 to 1.23.  Some things went wonky and I reverted to an earlier OS but there were still some non-crippling residuals that didn't affect the sound or any programmablity, so I never really worried about going all the way and correcting it complete.  I've just corrected the other issue now (missing wavetable names and garbled 'analogue' wave images), so hopefully the USB connect with work more stably with the MIO4 also.
  • The Rhythm Wolf.  Working.

    Forgot it had a USB port.  It was sitting on it's own output on the MIO4, but is now on the USB hub.  It's playing very nicely and sending it's sequencer notes out too.  I have it clocked by a gate out from the BSP so I can have it step at will and also play it with the BSP.  Now it's not so messy in there.
  • Good to know, have fancied getting one of those myself ;-)
  • They are great little machines with a few restrictions such as fixed MIDI channels, which is one of reasons to get a MIO4.  Another thing about them is the are inherently noisy, so really do need a gate on the output.  
    Out of production now.  I wanted to get a Tom Cat too but now finding very hard to source, both new and 2nd...
  • Working:
    Allen & Heath Xone K2
    DJ Tech­tools Midi Fighter 3D
    Roland SBX-1

    Not working:
    Edirol PCR-800
  • Hi - i notice in the first list that the novation launchpad is under "partially working"
    can you shed any light on what part of it does not work? Im looking to get an MIO4 specifically to use with a launchpad ;)
    Many thanks
  • From what I've heard, the MIDI works, but the lights don't. I haven't tested it personally. So it's a "try at your own risk" scenario...

  • edited September 2018

    I can confirm that the MIO 10 can see the following: Behringer DeepMind12, Elektron Digitakt and Elektron Analog 4.

    I have been unable to get the MIO 10 to see the Behringer BRC2000 yet. 

    I am still hoping I can get the MIO 10 to see a couple of Roli Seaboard Blocks and a Boss RC-505.

    Hope this helps.

    If there is any advice for Behringer BRC2000, Roli Seaboard Blocks and Boss RC-505, I am all ears. :)


  • Thanks for the info, have updated the list with the ones confirmed working. Can you confirm the others not working? I know we have tested the full size ROLI Seaboard and that definitely works, but we have not tested the Blocks.
  • Is there anything special that I need to do to make the roli work? Once I try that missing element, I will let you know. :)
    I just did a usb plugged into a hub. It did not appear like the other devices. 

  • Basically it will usually either just work or not work, depending on whether the MIDI device supports class-compliant USB-MIDI or not. There's not much you can do as an end-user, it all depends on the way the manufacturer has implemented their USB system.
  • Working:

    -Novation ReMote 25SL (has been reported not working by another poster, but mine does, on all ports (3 USB and 2 DIN). Powered over USB (UGreen powered USB 7 ports hub)

    -Pioneer/DSI Toraiz SP16
    -Pioneer/DSI Toraiz AS1
    -Elektron Digitone
    -Eventide TimeFactor
    -Eventide PitchFactor


Sign In or Register to comment.